mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-06 20:15:00 +08:00
506299a173
* [libproxy]Add new port. * [libmodman]Add new port. * [libproxy]Support windows, set dependency libmodman. * Add usage, add vcpkg-cmake-wrapper.cmake to libproxy. * add empty line to usage. * [libmodman]Fix undefined typeid in Visual Studio 2019. * [libproxy]Fix install libproxy.py error when it not exist. * Disable arm/uwp build. * Enable static build on UNIX. * [libproxy]Re-generate patches, delete default feature tools and use system libmodman. * [libproxy]Disable install libproxy.py. * [libproxy]Disable install Libproxy.pm and PLlibproxy. * [libproxy]DISABLE PARALLEL CONFIGURE * [libproxy]Revert 6f233cced1a51a086e5fea5bf290565d9847d4b7 * [libmodman/libproxy]Fix arm build.
16 lines
299 B
Diff
16 lines
299 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 51b0e5e..aa94b87 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -51,6 +51,10 @@ else()
|
|
endif()
|
|
endif()
|
|
|
|
+if (WIN32)
|
|
+ link_libraries(Advapi32)
|
|
+endif()
|
|
+
|
|
# Conditionally build bindings
|
|
if(NOT WIN32)
|
|
add_subdirectory(bindings)
|