mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-13 09:57:57 +08:00
8db63fc115
* [pangolin] Update to 0.6 * Update version files * Format manifest * Revert to CRLF in original patches * Update versions/p-/pangolin.json * Support osx and add features * Remove extra space line * Update versions/p-/pangolin.json * Remove unused options * Update versions/p-/pangolin.json * Add MAYBE_UNUSED_VARIABLES * Update versions/p-/pangolin.json
13 lines
410 B
Diff
13 lines
410 B
Diff
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
|
index 49dcf02..d448928 100644
|
|
--- a/src/CMakeLists.txt
|
|
+++ b/src/CMakeLists.txt
|
|
@@ -384,6 +384,7 @@ endif()
|
|
|
|
option(BUILD_PANGOLIN_FFMPEG "Build support for ffmpeg video input" ON)
|
|
if(BUILD_PANGOLIN_FFMPEG AND BUILD_PANGOLIN_VIDEO)
|
|
+ add_definitions(-DHAVE_FFMPEG_AVPIXELFORMAT)
|
|
find_package(FFMPEG QUIET)
|
|
if(FFMPEG_FOUND)
|
|
set(HAVE_FFMPEG 1)
|