mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-04 08:05:34 +08:00
9502b2044d
* [mathgl] Update to v2.5 and apply fixes * Update CI baseline
39 lines
1.4 KiB
Diff
39 lines
1.4 KiB
Diff
diff --git a/mgllab/CMakeLists.txt b/mgllab/CMakeLists.txt
|
|
index 1649104..eeec1c1 100644
|
|
--- a/mgllab/CMakeLists.txt
|
|
+++ b/mgllab/CMakeLists.txt
|
|
@@ -38,7 +38,11 @@ if(MGL_HAVE_FLTK)
|
|
set(mgllab_src ${mgllab_src} mgllab.rc)
|
|
endif(WIN32)
|
|
add_executable(mgllab ${mgllab_src} ${mgllab_hdr})
|
|
- target_link_libraries(mgllab mgl mgl-fltk ${FLTK_LIBRARIES})
|
|
+ if(WIN32)
|
|
+ target_link_libraries(mgllab mgl mgl-fltk mgl-fltk-static mgl-static getopt-static ${FLTK_LIBRARIES})
|
|
+ else(WIN32)
|
|
+ target_link_libraries(mgllab mgl mgl-fltk ${FLTK_LIBRARIES})
|
|
+ endif(WIN32)
|
|
install(
|
|
TARGETS mgllab
|
|
RUNTIME DESTINATION bin )
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index d0c779d..acd9d7f 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -579,10 +579,15 @@ if(enable-glut)
|
|
if(NOT MGL_HAVE_OPENGL)
|
|
message(SEND_ERROR "You have to enable OpenGL if you plan to use GLUT.")
|
|
endif(NOT MGL_HAVE_OPENGL)
|
|
- include(FindGLUT)
|
|
+ find_path(GLUT_INCLUDE_DIR freeglut.h PATH_SUFFIXES GL)
|
|
+ include(SelectLibraryConfigurations)
|
|
+ find_library(GLUT_LIBRARY_RELEASE NAMES freeglut)
|
|
+ find_library(GLUT_LIBRARY_DEBUG NAMES freeglutd)
|
|
+ select_library_configurations(GLUT)
|
|
if(NOT GLUT_FOUND)
|
|
message(SEND_ERROR "Couldn't find GLUT library.")
|
|
endif(NOT GLUT_FOUND)
|
|
+ include_directories(${GLUT_INCLUDE_DIR}/GL)
|
|
else(enable-glut)
|
|
set(MGL_HAVE_GLUT 0)
|
|
endif(enable-glut)
|