mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-09 23:08:14 +08:00
20 lines
824 B
Diff
20 lines
824 B
Diff
diff --git "a/CMakeLists.txt" "b/CMakeLists.txt"
|
|
index 679df4e..0a01d47 100644
|
|
--- "a/CMakeLists.txt"
|
|
+++ "b/CMakeLists.txt"
|
|
@@ -106,10 +106,10 @@ macro(install_suitesparse_project targetName headersList)
|
|
set_target_properties(${targetName} PROPERTIES PUBLIC_HEADER "${headersList}")
|
|
install(TARGETS ${targetName}
|
|
EXPORT SuiteSparse
|
|
- RUNTIME DESTINATION bin
|
|
- LIBRARY DESTINATION lib${LIB_POSTFIX}
|
|
- ARCHIVE DESTINATION lib${LIB_POSTFIX}
|
|
- PUBLIC_HEADER DESTINATION include/suitesparse
|
|
+ RUNTIME DESTINATION ${suitesparse_PKG_DIR}/$<$<CONFIG:Debug>:Debug/>bin
|
|
+ LIBRARY DESTINATION ${suitesparse_PKG_DIR}/$<$<CONFIG:Debug>:Debug/>lib
|
|
+ ARCHIVE DESTINATION ${suitesparse_PKG_DIR}/$<$<CONFIG:Debug>:Debug/>lib
|
|
+ PUBLIC_HEADER DESTINATION ${suitesparse_PKG_DIR}/include/suitesparse
|
|
)
|
|
endmacro()
|
|
|