mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-29 03:34:26 +08:00
e6c8c2bc05
* Build with CMake [skip actions] * Update to 3.5.0 RC1 [skip actions] * Update to 3.5.0RC2 * Use GDAL_USE_INTERNAL_LIBS=OFF * Use lower-case config path * Add LERC support * Fix tiff linkage in libgeotiff * uwp is unsupported * core doesn't imply lerc * Drop legacy build * Feature and portfile cleanup [skip actions] * Cleanup wrapper * Pass on libspatialite usage requirements * Update versions * Remove hfd5/netcdf from default for android * Update versions * Fix wrapper * Update versions * Fix libgeotiff config * The wrapper needs pkgconf for libspatialite * Update versions * Remove obsolete patch * Update to v3.5.1-RC1 * Burn host triplet into config, require pkg-config * Fix libspatialite link libraries [skip actions] * Update versions in manifests * Update versions * Remove obsolete wrapper code [skip actions] Complements 5c4f512. * Update to 3.5.1RC2 [skip actions] * Handle additional link dependencies using pkg-config [skip actions] * GDAL's find modules rely on PkgConfig * Update to 3.5.1 * Update versions
48 lines
1.7 KiB
Diff
48 lines
1.7 KiB
Diff
diff --git a/libgeotiff/CMakeLists.txt b/libgeotiff/CMakeLists.txt
|
|
index 1840258..fcf2dd0 100644
|
|
--- a/libgeotiff/CMakeLists.txt
|
|
+++ b/libgeotiff/CMakeLists.txt
|
|
@@ -311,17 +311,18 @@ endif()
|
|
SET_TARGET_PROPERTIES(${GEOTIFF_LIBRARY_TARGET} PROPERTIES
|
|
OUTPUT_NAME ${GEOTIFF_LIB_NAME})
|
|
|
|
-set(CONFIG_DEPENDENCIES "")
|
|
+set(CONFIG_PUBLIC_DEPENDENCIES "")
|
|
+set(CONFIG_PRIVATE_DEPENDENCIES "")
|
|
if(TARGET TIFF::TIFF)
|
|
set(TIFF_LIBRARIES TIFF::TIFF)
|
|
- string(APPEND CONFIG_DEPENDENCIES " find_dependency(TIFF)\n")
|
|
+ string(APPEND CONFIG_PUBLIC_DEPENDENCIES "find_dependency(TIFF)\n")
|
|
endif()
|
|
target_link_libraries(${GEOTIFF_LIBRARY_TARGET} PUBLIC
|
|
${TIFF_LIBRARIES})
|
|
|
|
if(TARGET PROJ::proj)
|
|
set(PROJ_LIBRARIES PROJ::proj)
|
|
- string(APPEND CONFIG_DEPENDENCIES " find_dependency(PROJ CONFIG)\n")
|
|
+ string(APPEND CONFIG_PRIVATE_DEPENDENCIES " find_dependency(PROJ CONFIG)\n")
|
|
endif()
|
|
target_link_libraries(${GEOTIFF_LIBRARY_TARGET} PRIVATE
|
|
${PROJ_LIBRARIES})
|
|
diff --git a/libgeotiff/cmake/project-config.cmake.in b/libgeotiff/cmake/project-config.cmake.in
|
|
index 3690489..87de991 100644
|
|
--- a/libgeotiff/cmake/project-config.cmake.in
|
|
+++ b/libgeotiff/cmake/project-config.cmake.in
|
|
@@ -22,13 +22,14 @@ set (@PROJECT_NAME@_BINARY_DIRS "${_ROOT}/bin")
|
|
unset (_ROOT)
|
|
unset (_DIR)
|
|
|
|
+include(CMakeFindDependencyMacro)
|
|
+@CONFIG_PUBLIC_DEPENDENCIES@
|
|
set (@PROJECT_NAME@_LIBRARIES @GEOTIFF_LIBRARY_TARGET@)
|
|
if("@BUILD_SHARED_LIBS@")
|
|
set (@PROJECT_NAME@_SHARED_LIBRARIES ${@PROJECT_NAME@_LIBRARIES})
|
|
else()
|
|
set (@PROJECT_NAME@_STATIC_LIBRARIES ${@PROJECT_NAME@_LIBRARIES})
|
|
- include(CMakeFindDependencyMacro)
|
|
-@CONFIG_DEPENDENCIES@
|
|
+@CONFIG_PRIVATE_DEPENDENCIES@
|
|
endif()
|
|
|
|
if(NOT @PROJECT_NAME@_FIND_QUIETLY)
|