mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-28 03:10:57 +08:00
b93bc1b81e
* Use official zstd config * Require packages for features * Test zstd in CI * Enable libtiffxx on arm * Update versions * Assume ZSTD_decompressStream * Don't put targets into TIFF_LIBRARIES * [qt5-imageformats] Use libtiff-4.pc * [zstd] Revise thread lib export * Mark link libs with LINK_ONLY * Revert "[zstd] Revise thread lib export" This reverts commit a99e6378a67adc68e9e43e6e193206a5ddcba60e. * [qt5-imageformats] Get all tiff lflags * [gdk-pixbuf] Use libtiff-4 pc file for msvc * [qtimageformat] Workaround for QTBUG-95052
14 lines
541 B
Diff
14 lines
541 B
Diff
diff --git a/meson.build b/meson.build
|
|
index b5280f3..4927ed5 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -333,7 +333,7 @@ tiff_opt = get_option('tiff')
|
|
if not tiff_opt.disabled() and not native_windows_loaders
|
|
# We currently don't have a fallback subproject, but this handles error
|
|
# reporting if tiff_opt is enabled.
|
|
- tiff_dep = dependency(is_msvc_like ? 'tiff' : 'libtiff-4', required: tiff_opt)
|
|
+ tiff_dep = dependency(false ? 'tiff' : 'libtiff-4', required: tiff_opt)
|
|
|
|
if tiff_dep.found()
|
|
enabled_loaders += 'tiff'
|