vcpkg/ports/ableton/replace_local_asiostandalone_by_vcpkg_asio.patch
JoergAtGithub 06d29adda9
[new port] Ableton Link (#25438)
* Initial port for Ableton Link

* Added missing versions/a-/ableton.json file

* Added double quotes to all relative paths in portfile.cmake

* Removed CMakeLists.txt file from the installed files

* Use Catch2 only in CMakeLists.txt, when test features are enabled

* Made find_package asio conditional too
2022-07-05 15:49:35 -07:00

22 lines
767 B
Diff

diff a/cmake_include/AsioStandaloneConfig.cmake b/AsioStandaloneConfig.cmake
--- a/cmake_include/AsioStandaloneConfig.cmake
+++ b/cmake_include/AsioStandaloneConfig.cmake
@@ -1,6 +1,12 @@
add_library(AsioStandalone::AsioStandalone IMPORTED INTERFACE)
+if (LINK_BUILD_ASIO MATCHES "ON")
-set_property(TARGET AsioStandalone::AsioStandalone APPEND PROPERTY
- INTERFACE_INCLUDE_DIRECTORIES
- ${CMAKE_CURRENT_LIST_DIR}/../modules/asio-standalone/asio/include
-)
+ find_package(asio REQUIRED)
+ if(asio_FOUND)
+ message(STATUS "Dependency asio found in ${asio_DIR}")
+ set_property(TARGET AsioStandalone::AsioStandalone APPEND PROPERTY
+ INTERFACE_INCLUDE_DIRECTORIES
+ ${asio_DIR}/../../include
+ )
+ endif()
+endif()