mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-29 03:34:26 +08:00
13156b1cf6
* Update alembic to 1.8.3, use imath dependency * Update git-tree hash * Various fixes and cleanups * Update git-tree hash * Various fixes * Update git-tree hash * Experimentally enable all platforms * Update git-tree hash * Various improvements * Update git-tree hash * Fix x64 Linux build * Update git-tree hash * Revert "Fix x64 Linux build" This reverts commit 154d51fcca7c413959f9cf78ea021c08399b16e4. * Fix x64 Linux build using patch * Update git-tree hash * Make HDF5 support optional and disabled by default * Update git-tree hash * Fix abcconvert tool * Use alternative method to fix DLL location, also fixes PDB inclusion * Update git-tree hash * Fix supported platforms * Update git-tree hash Co-authored-by: chausner <chausner@users.noreply.github.com>
20 lines
771 B
Diff
20 lines
771 B
Diff
Workaround for https://github.com/alembic/alembic/issues/309
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -125,14 +125,6 @@ IF (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
|
|
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility=hidden")
|
|
ENDIF()
|
|
|
|
-# Set some debug vs opt flags
|
|
-if ("${CMAKE_BUILD_TYPE}" MATCHES "Debug" AND NOT MSVC)
|
|
- add_definitions(-Wall -Werror -Wextra -Wno-unused-parameter -Wno-deprecated)
|
|
- if((CMAKE_CXX_COMPILER_ID MATCHES "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 7.0) OR
|
|
- CMAKE_CXX_COMPILER_ID MATCHES "CLANG")
|
|
- add_definitions( -Wno-error=implicit-fallthrough)
|
|
- endif()
|
|
-endif()
|
|
|
|
IF (NOT ${WINDOWS})
|
|
SET(EXTERNAL_MATH_LIBS "-lm")
|