vcpkg/ports/cpuid/fix-LNK2019.patch

14 lines
415 B
Diff

diff --git a/libcpuid/CMakeLists.txt b/libcpuid/CMakeLists.txt
index 09189ef..fa3f6ff 100644
--- a/libcpuid/CMakeLists.txt
+++ b/libcpuid/CMakeLists.txt
@@ -21,7 +21,7 @@ if(UNIX)
add_compile_definitions(_GNU_SOURCE)
endif(UNIX)
-if("${MSVC_CXX_ARCHITECTURE_ID}" MATCHES "x64")
+if(MSVC AND CMAKE_SYSTEM_PROCESSOR MATCHES "x86_64|AMD64|x64")
list(APPEND cpuid_sources masm-x64.asm)
endif()