mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-28 03:10:57 +08:00
297ff7ba3e
* Consolidate netcdf-c ZLIB patching * Update to 4.8.1, refresh patches * Resolve parameter warning * Decouple netcdf-4 feature from hdf5 * Expose NCZarr features * Break vcpkg CI cascade * Fix hdf5 szip support detection for static linkage * Allow curl, hdf5, libzip with minimal dependencies * Disable fatal warnings on uwp * Update versions * Fix libzip dependency * Fix and simplify szip config patch * Revert nczarr-s3 feature for now * Update versions * [skip actions] CI * [skip actions] Debug ci failure * Revert "[skip actions] Debug ci failure" This reverts commit 03f3d52623026e9f16f8be067a07499aa5788b55.
14 lines
434 B
Diff
14 lines
434 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 6b39f0e..507eb4c 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -2028,7 +2028,7 @@ ADD_SUBDIRECTORY(docs)
|
|
# install them in the binary dir. Grab all of the .libs, put them
|
|
# in the libdir.
|
|
##
|
|
-IF(MSVC)
|
|
+IF(MSVC AND NOT DISABLE_INSTALL_DEPENDENCIES)
|
|
FILE(GLOB COPY_FILES ${CMAKE_PREFIX_PATH}/lib/*.lib)
|
|
INSTALL(FILES ${COPY_FILES}
|
|
DESTINATION ${CMAKE_INSTALL_LIBDIR}
|