mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-29 03:34:26 +08:00
401578455f
* [OpenCV4] update to v4.5.5 * [OpenCV] bump version * [gstreamer] fix build for opencv * fix references * [vcpkg-tool-meson] fix nuget packaging * fix references * [gstreamer] fix references * [ogre] update vcpkg tools * fix references * [OpenCV4] fixes from CI runs * fix references * [OpenCV4] force python module also in debug builds * fix references * [harfbuzz] fix cmake config * harfbuzz fixes * fix references * [OpenCV4] remove unnecessary lines from patches * fix references * fix references * [harfbuzz] bump version * [harfbuzz] fix for single config builds * fix references * freetype fixes * fix references * fix ogre references * fix references, again * python when building static windows opencv libraries is unsupported * fix references * fix * refs * use required when necessary * fix references * do not use config for hdf5, use internal module * fix references * use proper spelling for freetype config cmake * fix references * [OpenCV] restore versions after merge * fix references * [leptonica] fix building * fix references * do not require package in optional features * £fix references * fix python feat * update version * update version * [ffmpeg] remove opengl feat on arm64-windows * format manifest * fix references * fix cuda/nvidia features compatibility matrix * fix manifest * fix * fix * fix references * fix references, again * move CONTROL to manifest * [gstreamer] bump versions * fix references Co-authored-by: Lily Wang <v-lilywang@microsoft.com>
20 lines
752 B
Diff
20 lines
752 B
Diff
--- a/src/CMakeLists.txt
|
|
+++ b/src/CMakeLists.txt
|
|
@@ -14,7 +14,6 @@ if (MSVC)
|
|
set_source_files_properties(${src} PROPERTIES LANGUAGE CXX)
|
|
endif()
|
|
|
|
-string(REPLACE "-O3" "-O2" CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE}")
|
|
|
|
add_library (leptonica ${src} ${hdr})
|
|
set_target_properties (leptonica PROPERTIES VERSION ${VERSION_PLAIN})
|
|
@@ -52,7 +52,7 @@ if (TIFF_LIBRARIES)
|
|
endif()
|
|
if (WEBP_FOUND)
|
|
target_include_directories (leptonica PUBLIC ${WEBP_INCLUDE_DIRS})
|
|
- target_link_libraries (leptonica ${WEBP_LIBRARIES})
|
|
+ target_link_libraries (leptonica WebP::webp WebP::libwebpmux)
|
|
endif()
|
|
if (ZLIB_LIBRARIES)
|
|
target_include_directories (leptonica PUBLIC ${ZLIB_INCLUDE_DIRS})
|