mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-01 21:58:55 +08:00
f0767d3bd9
Add missing boost definition using a patch. Better compile from HEAD.
14 lines
386 B
Diff
14 lines
386 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 0405dca2..00e5238e 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -168,6 +168,8 @@ if(CMAKE_COMPILER_IS_MSVC)
|
|
endif()
|
|
endif()
|
|
|
|
+add_definitions(-DBOOST_UUID_RANDOM_GENERATOR_COMPAT)
|
|
+
|
|
if(CMAKE_COMPILER_IS_PATHSCALE)
|
|
if("${CMAKE_CXX_FLAGS}" STREQUAL "")
|
|
SET(CMAKE_CXX_FLAGS "-Wno-uninitialized -zerouv -pthread -mp")
|