vcpkg/ports/pcl/boost_uuid_random_generator_compat.patch
Claudio Fantacci f0767d3bd9 Fix PCL compile tools (#3301)
Add missing boost definition using a patch.

Better compile from HEAD.
2018-04-24 11:09:12 -07:00

14 lines
386 B
Diff

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0405dca2..00e5238e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -168,6 +168,8 @@ if(CMAKE_COMPILER_IS_MSVC)
endif()
endif()
+add_definitions(-DBOOST_UUID_RANDOM_GENERATOR_COMPAT)
+
if(CMAKE_COMPILER_IS_PATHSCALE)
if("${CMAKE_CXX_FLAGS}" STREQUAL "")
SET(CMAKE_CXX_FLAGS "-Wno-uninitialized -zerouv -pthread -mp")