mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-28 19:25:27 +08:00
078f136afc
* glog upgrade * tmp * is glog initialized * fix glog dependency * fix glog dependency * fix folly abort call * delete buildtrees * fix folly abort call * delete useless lines * fix caffe2 isglog initialized * make patches shorter * glog fix typo * glog fix tab * Remove cpp patch since we don't need it * Revert 6b8759a860d5307a9ae31247eff3bce48f56aeaf Co-authored-by: JackBoosY <yuzaiyang@beyondsoft.com>
34 lines
925 B
Diff
34 lines
925 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 846b444..20441d1 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -1027,7 +1027,7 @@ write_basic_package_version_file (
|
|
|
|
export (TARGETS glog NAMESPACE glog:: FILE glog-targets.cmake)
|
|
export (PACKAGE glog)
|
|
-
|
|
+if(0)
|
|
get_filename_component (_PREFIX "${CMAKE_INSTALL_PREFIX}" ABSOLUTE)
|
|
|
|
# Directory containing the find modules relative to the config install
|
|
@@ -1063,6 +1063,7 @@ file (INSTALL
|
|
"
|
|
COMPONENT Development
|
|
)
|
|
+endif()
|
|
|
|
install (FILES
|
|
${CMAKE_CURRENT_BINARY_DIR}/glog-config.cmake
|
|
diff --git a/glog-config.cmake.in b/glog-config.cmake.in
|
|
index 5c5c9c0..31fac52 100644
|
|
--- a/glog-config.cmake.in
|
|
+++ b/glog-config.cmake.in
|
|
@@ -5,7 +5,6 @@ endif (CMAKE_VERSION VERSION_LESS @glog_CMake_VERSION@)
|
|
@PACKAGE_INIT@
|
|
|
|
include (CMakeFindDependencyMacro)
|
|
-include (${CMAKE_CURRENT_LIST_DIR}/glog-modules.cmake)
|
|
|
|
@gflags_DEPENDENCY@
|
|
@Unwind_DEPENDENCY@
|