mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-04 16:17:13 +08:00
d6285bc24b
* [expat] Update the version to 2.2.9(support uwp) * [readosm] Fix expat.lib cannot be found * Remove expat:arm-uwp and expat:x64-uwp from fail list in ci.baseline.txt * [apr-util,io2d,skia] Fix expat cannot be found and also update expat * [many ports] Add supports and fix the regressions * Fix new regressions * Fix typo * [io2d] Update expat patch * [io2d,libkml,skia] Fix expat cannot find and also fix typo * [expat] Remove usage * [libkml,vtk] Update expat patch and fix static build * [wxwidgets] Fix static build caused by expat cannot found * Update as review suggestion * Add Port-Version * Remove evpp:x64-osx=fail from ci.baseline.txt * [wxwidgest] Remove unnecessary spaces * [itk] Fix expat cannot be found * fix cmake test port * [wxwidgets] Update Port-Version Co-authored-by: Nicole Mazzuca <mazzucan@outlook.com>
55 lines
2.1 KiB
Diff
55 lines
2.1 KiB
Diff
diff --git a/Modules/IO/GDCM/itk-module.cmake b/Modules/IO/GDCM/itk-module.cmake
|
|
index 2703612..51f0214 100644
|
|
--- a/Modules/IO/GDCM/itk-module.cmake
|
|
+++ b/Modules/IO/GDCM/itk-module.cmake
|
|
@@ -1,7 +1,7 @@
|
|
set(DOCUMENTATION "This module contains ITK ImageIO classes for the <a
|
|
href=\"http://sourceforge.net/projects/gdcm/\">Grassroots DICOM (GDCM)</a> based
|
|
readers and writers of the medical imaging DICOM standard.")
|
|
-
|
|
+find_package(expat CONFIG REQUIRED)
|
|
itk_module(ITKIOGDCM
|
|
ENABLE_SHARED
|
|
DEPENDS
|
|
@@ -9,6 +9,7 @@ itk_module(ITKIOGDCM
|
|
ITKIOImageBase
|
|
PRIVATE_DEPENDS
|
|
ITKGDCM
|
|
+ ITKExpat
|
|
TEST_DEPENDS
|
|
ITKTestKernel
|
|
ITKGDCM
|
|
diff --git a/Modules/ThirdParty/Expat/CMakeLists.txt b/Modules/ThirdParty/Expat/CMakeLists.txt
|
|
index f69709d..9b49323 100644
|
|
--- a/Modules/ThirdParty/Expat/CMakeLists.txt
|
|
+++ b/Modules/ThirdParty/Expat/CMakeLists.txt
|
|
@@ -5,10 +5,12 @@ option(ITK_USE_SYSTEM_EXPAT "Use system-installed expat" ${ITK_USE_SYSTEM_LIBRAR
|
|
mark_as_advanced(ITK_USE_SYSTEM_EXPAT)
|
|
|
|
if(ITK_USE_SYSTEM_EXPAT)
|
|
- find_package(EXPAT REQUIRED)
|
|
- set(ITKExpat_INCLUDE_DIRS ${ITKExpat_BINARY_DIR}/src )
|
|
- set(ITKExpat_SYSTEM_INCLUDE_DIRS "${EXPAT_INCLUDE_DIR}")
|
|
- set(ITKExpat_LIBRARIES "${EXPAT_LIBRARY}")
|
|
+ find_package(expat CONFIG REQUIRED)
|
|
+ if(WIN32 AND NOT MINGW)
|
|
+ set(ITKExpat_LIBRARIES expat::libexpat)
|
|
+ else()
|
|
+ set(ITKExpat_LIBRARIES expat::expat)
|
|
+ endif()
|
|
set(ITKExpat_NO_SRC 1)
|
|
else()
|
|
set(ITKExpat_INCLUDE_DIRS
|
|
diff --git a/Modules/ThirdParty/GIFTI/src/gifticlib/CMakeLists.txt b/Modules/ThirdParty/GIFTI/src/gifticlib/CMakeLists.txt
|
|
index 3f83225..c7ddbbe 100644
|
|
--- a/Modules/ThirdParty/GIFTI/src/gifticlib/CMakeLists.txt
|
|
+++ b/Modules/ThirdParty/GIFTI/src/gifticlib/CMakeLists.txt
|
|
@@ -11,6 +11,7 @@ set(GIFTI_INSTALL_INCLUDE_DIR "${CMAKE_INSTALL_PREFIX}/include/gifti")
|
|
|
|
if("${ITK_VERSION_MAJOR}" GREATER 0.0)
|
|
# ITK provides expat and zlib.
|
|
+ find_package(expat CONFIG REQUIRED)
|
|
include_directories(${ITKNIFTI_INCLUDE_DIRS})
|
|
set(PACKAGE_PREFIX "ITK")
|
|
set(EXPAT_LIBRARIES ${ITKExpat_LIBRARIES})
|