mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-27 10:21:07 +08:00
9d3a91cce2
note: Actually, static build is perfectly fine but the cmake always build static and dynamic library togather, in the static environment, dynamic build will fail due link error. I twisted a patch to the CMakeLists.txt to make dynamic build happy when building static.
47 lines
1.0 KiB
Diff
47 lines
1.0 KiB
Diff
diff --git a/src/bsoncxx/CMakeLists.txt b/src/bsoncxx/CMakeLists.txt
|
|
index a9a7ada..f4534b1 100644
|
|
--- a/src/bsoncxx/CMakeLists.txt
|
|
+++ b/src/bsoncxx/CMakeLists.txt
|
|
@@ -117,9 +117,15 @@ if (WIN32)
|
|
)
|
|
endif()
|
|
|
|
-add_library(bsoncxx SHARED
|
|
- ${bsoncxx_sources}
|
|
-)
|
|
+if(ENABLE_SHARED)
|
|
+ add_library(bsoncxx SHARED
|
|
+ ${bsoncxx_sources}
|
|
+ )
|
|
+else()
|
|
+ add_library(bsoncxx SHARED
|
|
+ exception/error_code.cpp
|
|
+ )
|
|
+endif()
|
|
|
|
set(bsoncxx_libs ${LIBBSON_LIBRARIES})
|
|
|
|
diff --git a/src/mongocxx/CMakeLists.txt b/src/mongocxx/CMakeLists.txt
|
|
index 2ef54e4..a2c8ca4 100644
|
|
--- a/src/mongocxx/CMakeLists.txt
|
|
+++ b/src/mongocxx/CMakeLists.txt
|
|
@@ -134,9 +134,15 @@ set_target_properties(mongocxx_mocked PROPERTIES
|
|
VERSION ${MONGOCXX_VERSION}
|
|
)
|
|
|
|
-add_library(mongocxx SHARED
|
|
- ${mongocxx_sources}
|
|
-)
|
|
+if(ENABLE_SHARED)
|
|
+ add_library(mongocxx SHARED
|
|
+ ${mongocxx_sources}
|
|
+ )
|
|
+else()
|
|
+ add_library(mongocxx SHARED
|
|
+ exception/error_code.cpp
|
|
+ )
|
|
+endif()
|
|
|
|
set_target_properties (mongocxx PROPERTIES
|
|
OUTPUT_NAME mongocxx
|