mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-28 03:10:57 +08:00
3bc5ff7f7a
* [juce] add port for JUCE * [juce] install linux dependencies in ci * [juce] fix tool installation and cleaning * [juce] fix freetype includes for juce graphics * [juce] fix freetype includes for juceaide * [juce] simplify the freetype find check * [juce] use find_path in addition for freetype * [juce] allow setting freetype usage for juceaide * [juce] forward freetype setting + guard with option * [juce] do not use freetype for console apps * [juce] freetype is needed for console apps on Linux * [juce] link freetype on Linux for juce_build_tools * [juce] forward-vcpkg-toolchain for Builder * [juce] fix linux dependencies + forward vcpkg args * [juce] fix installation of juce tools and juce extra tools * [juce] use jack2 only on Linux * [juce] add docs for targets and descriptions * [juce] fix installation path references in CMake * [juce] do not move Cmake files + fix tool install dir * [juce] remove libwebkit2gtk-4.0-dev from ci * [juce] add ONLY_STATIC_LIBRARY to the port for windows * [juce] fix the CMake path installation paths * Revert "[juce] add ONLY_STATIC_LIBRARY to the port for windows" This reverts commit 0eb5c6f1c6baa48cebf03b6bd36641528582d5ff. * [juce] improve linux dependencies find/linkage * [juce] remove libxcomposite-dev from vm
16 lines
561 B
Diff
16 lines
561 B
Diff
diff --git a/extras/AudioPluginHost/CMakeLists.txt b/extras/AudioPluginHost/CMakeLists.txt
|
|
index 852796383..37a5306c9 100644
|
|
--- a/extras/AudioPluginHost/CMakeLists.txt
|
|
+++ b/extras/AudioPluginHost/CMakeLists.txt
|
|
@@ -51,7 +51,7 @@ target_compile_definitions(AudioPluginHost PRIVATE
|
|
JUCE_CONTENT_SHARING=1
|
|
JUCE_DIRECTSOUND=1
|
|
JUCE_DISABLE_CAUTIOUS_PARAMETER_ID_CHECKING=1
|
|
- JUCE_PLUGINHOST_LADSPA=1
|
|
+ JUCE_PLUGINHOST_LADSPA=${JUCE_PLUGINHOST_LADSPA}
|
|
JUCE_PLUGINHOST_LV2=1
|
|
JUCE_PLUGINHOST_VST3=1
|
|
JUCE_PLUGINHOST_VST=0
|
|
--
|
|
2.34.1
|