mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-28 03:10:57 +08:00
3bc5ff7f7a
* [juce] add port for JUCE * [juce] install linux dependencies in ci * [juce] fix tool installation and cleaning * [juce] fix freetype includes for juce graphics * [juce] fix freetype includes for juceaide * [juce] simplify the freetype find check * [juce] use find_path in addition for freetype * [juce] allow setting freetype usage for juceaide * [juce] forward freetype setting + guard with option * [juce] do not use freetype for console apps * [juce] freetype is needed for console apps on Linux * [juce] link freetype on Linux for juce_build_tools * [juce] forward-vcpkg-toolchain for Builder * [juce] fix linux dependencies + forward vcpkg args * [juce] fix installation of juce tools and juce extra tools * [juce] use jack2 only on Linux * [juce] add docs for targets and descriptions * [juce] fix installation path references in CMake * [juce] do not move Cmake files + fix tool install dir * [juce] remove libwebkit2gtk-4.0-dev from ci * [juce] add ONLY_STATIC_LIBRARY to the port for windows * [juce] fix the CMake path installation paths * Revert "[juce] add ONLY_STATIC_LIBRARY to the port for windows" This reverts commit 0eb5c6f1c6baa48cebf03b6bd36641528582d5ff. * [juce] improve linux dependencies find/linkage * [juce] remove libxcomposite-dev from vm
33 lines
1.8 KiB
Diff
33 lines
1.8 KiB
Diff
diff --git a/extras/Build/juceaide/CMakeLists.txt b/extras/Build/juceaide/CMakeLists.txt
|
|
index 163f203cc..f4cdba7f7 100644
|
|
--- a/extras/Build/juceaide/CMakeLists.txt
|
|
+++ b/extras/Build/juceaide/CMakeLists.txt
|
|
@@ -111,6 +111,25 @@ else()
|
|
"-DCMAKE_BUILD_TYPE=Debug"
|
|
"-DJUCE_BUILD_HELPER_TOOLS=ON"
|
|
"-DCMAKE_INSTALL_PREFIX=${CMAKE_INSTALL_PREFIX}"
|
|
+ # forward vcpkg flags
|
|
+ "-DCMAKE_TOOLCHAIN_FILE=${CMAKE_TOOLCHAIN_FILE}"
|
|
+ "-DCMAKE_SYSTEM_NAME=${CMAKE_SYSTEM_NAME}"
|
|
+ "-DCMAKE_ERROR_ON_ABSOLUTE_INSTALL_DESTINATION=${CMAKE_ERROR_ON_ABSOLUTE_INSTALL_DESTINATION}"
|
|
+ "-DCMAKE_EXPORT_NO_PACKAGE_REGISTRY=${CMAKE_EXPORT_NO_PACKAGE_REGISTRY}"
|
|
+ "-DCMAKE_FIND_PACKAGE_NO_PACKAGE_REGISTRY=${CMAKE_FIND_PACKAGE_NO_PACKAGE_REGISTRY}"
|
|
+ "-DCMAKE_FIND_PACKAGE_NO_SYSTEM_PACKAGE_REGISTRY=${CMAKE_FIND_PACKAGE_NO_SYSTEM_PACKAGE_REGISTRY}"
|
|
+ "-DCMAKE_INSTALL_SYSTEM_RUNTIME_LIBS_SKIP=${CMAKE_INSTALL_SYSTEM_RUNTIME_LIBS_SKIP}"
|
|
+ "-DCMAKE_VERBOSE_MAKEFILE=${CMAKE_VERBOSE_MAKEFILE}"
|
|
+ "-DVCPKG_APPLOCAL_DEPS=${VCPKG_APPLOCAL_DEPS}"
|
|
+ "-DVCPKG_CHAINLOAD_TOOLCHAIN_FILE=${VCPKG_CHAINLOAD_TOOLCHAIN_FILE}"
|
|
+ "-DVCPKG_CRT_LINKAGE=${VCPKG_CRT_LINKAGE}"
|
|
+ "-DVCPKG_MANIFEST_INSTALL=${VCPKG_MANIFEST_INSTALL}"
|
|
+ "-DVCPKG_PLATFORM_TOOLSET=${VCPKG_PLATFORM_TOOLSET}"
|
|
+ "-DVCPKG_SET_CHARSET_FLAG=${VCPKG_SET_CHARSET_FLAG}"
|
|
+ "-DVCPKG_TARGET_ARCHITECTURE=${VCPKG_TARGET_ARCHITECTURE}"
|
|
+ "-DVCPKG_TARGET_TRIPLET=${VCPKG_TARGET_TRIPLET}"
|
|
+ "-D_VCPKG_INSTALLED_DIR=${_VCPKG_INSTALLED_DIR}"
|
|
+ "-D_VCPKG_ROOT_DIR=${_VCPKG_ROOT_DIR}"
|
|
${extra_compiler_flag_arguments}
|
|
WORKING_DIRECTORY "${JUCE_SOURCE_DIR}"
|
|
OUTPUT_VARIABLE command_output
|
|
--
|
|
2.34.1
|