vcpkg/ports/zxing-cpp/0003-fix-dependency-bigint.patch
Jack·Boos·Yu 9211f80ed7
[bigint/zxing-cpp] Adapter xcode 5.1.1 and set it as a dependency of zxing-cpp (#13129)
* [bigint] Adapter xcode 5.1.1

* [bigint] Add vcpkg-cmake-wrapper

* [zxing-cpp] use vcpkg bigint instead
2020-08-27 20:24:39 -07:00

51 lines
1.6 KiB
Diff

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54071bd..0edd0e9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,6 +44,12 @@ if(WIN32)
set(CMAKE_DEBUG_POSTFIX -debug)
endif()
+# Bigint
+find_package(bigint CONFIG REQUIRED)
+
+include_directories(${BIGINT_INCLUDE_DIRS})
+link_libraries(${BIGINT_LIBRARIES})
+
# OpenCV classes
if(WITH_OPENCV)
find_package(OpenCV REQUIRED)
diff --git a/source_files.cmake b/source_files.cmake
index db3d8d4..39abe82 100644
--- a/source_files.cmake
+++ b/source_files.cmake
@@ -1,28 +1,4 @@
set(LIBZXING_FILES
- core/src/bigint/BigInteger.cc
- core/src/bigint/BigInteger.cc
- core/src/bigint/BigInteger.hh
- core/src/bigint/BigInteger.hh
- core/src/bigint/BigIntegerAlgorithms.cc
- core/src/bigint/BigIntegerAlgorithms.cc
- core/src/bigint/BigIntegerAlgorithms.hh
- core/src/bigint/BigIntegerAlgorithms.hh
- core/src/bigint/BigIntegerLibrary.hh
- core/src/bigint/BigIntegerLibrary.hh
- core/src/bigint/BigIntegerUtils.cc
- core/src/bigint/BigIntegerUtils.cc
- core/src/bigint/BigIntegerUtils.hh
- core/src/bigint/BigIntegerUtils.hh
- core/src/bigint/BigUnsigned.cc
- core/src/bigint/BigUnsigned.cc
- core/src/bigint/BigUnsigned.hh
- core/src/bigint/BigUnsigned.hh
- core/src/bigint/BigUnsignedInABase.cc
- core/src/bigint/BigUnsignedInABase.cc
- core/src/bigint/BigUnsignedInABase.hh
- core/src/bigint/BigUnsignedInABase.hh
- core/src/bigint/NumberlikeArray.hh
- core/src/bigint/NumberlikeArray.hh
core/src/zxing/aztec/AztecDetectorResult.cpp
core/src/zxing/aztec/AztecDetectorResult.h
core/src/zxing/aztec/AztecReader.cpp