mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-29 03:34:26 +08:00
91dd61bd44
* [libwebp] Update to 1.3.0 * Fix [core] on x64-osx * Fix features and dependencies * Cleanup tool installation * Usage * Lift restriction for vwebp tool * [mapnik] Fix libwebp * [qt5-imageformats] Use libwebp pc files * Revert "Lift restriction for vwebp tool" This reverts commit 42e0273f654117844ae317c06cbaf521d70462e4. * [gdal] Use upstream WebP config * Revert no longer necessary changes to mapnik. * Remove unnecessary patch that git checkout didn't remove. --------- Co-authored-by: Billy Robert O'Neal III <bion@microsoft.com>
22 lines
721 B
Diff
22 lines
721 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 636eef7..80361f1 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -452,6 +452,7 @@ endif()
|
|
if(WEBP_BUILD_ANIM_UTILS
|
|
OR WEBP_BUILD_CWEBP
|
|
OR WEBP_BUILD_DWEBP
|
|
+ OR WEBP_BUILD_EXTRAS
|
|
OR WEBP_BUILD_GIF2WEBP
|
|
OR WEBP_BUILD_IMG2WEBP
|
|
OR WEBP_BUILD_VWEBP
|
|
@@ -488,6 +489,8 @@ if(WEBP_BUILD_ANIM_UTILS
|
|
TARGET exampleutil imageioutil imagedec imageenc
|
|
PROPERTY INCLUDE_DIRECTORIES ${CMAKE_CURRENT_SOURCE_DIR}/src
|
|
${CMAKE_CURRENT_BINARY_DIR}/src)
|
|
+ target_include_directories(imagedec PRIVATE ${WEBP_DEP_IMG_INCLUDE_DIRS})
|
|
+ target_include_directories(imageenc PRIVATE ${WEBP_DEP_IMG_INCLUDE_DIRS})
|
|
endif()
|
|
|
|
if(WEBP_BUILD_DWEBP)
|