mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-27 18:31:15 +08:00
d843856f29
* Upgrade libjpeg-turbo to 2.1.2 * Update version files * Update to latest vcpkg functions * Format/version * Fix * Update ports/libjpeg-turbo/portfile.cmake Co-authored-by: JonLiu1993 <63675417+JonLiu1993@users.noreply.github.com> * CR * Fix version * Update patch * Fix * Version Co-authored-by: JonLiu1993 <63675417+JonLiu1993@users.noreply.github.com>
14 lines
542 B
Diff
14 lines
542 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 6dd83d3a..5cd717f5 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -54,7 +54,7 @@ message(STATUS "VERSION = ${VERSION}, BUILD = ${BUILD}")
|
|
|
|
# Detect CPU type and whether we're building 64-bit or 32-bit code
|
|
math(EXPR BITS "${CMAKE_SIZEOF_VOID_P} * 8")
|
|
-string(TOLOWER ${CMAKE_SYSTEM_PROCESSOR} CMAKE_SYSTEM_PROCESSOR_LC)
|
|
+string(TOLOWER "${CMAKE_SYSTEM_PROCESSOR}" CMAKE_SYSTEM_PROCESSOR_LC)
|
|
set(COUNT 1)
|
|
foreach(ARCH ${CMAKE_OSX_ARCHITECTURES})
|
|
if(COUNT GREATER 1)
|