mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-06 11:22:52 +08:00
078f136afc
* glog upgrade * tmp * is glog initialized * fix glog dependency * fix glog dependency * fix folly abort call * delete buildtrees * fix folly abort call * delete useless lines * fix caffe2 isglog initialized * make patches shorter * glog fix typo * glog fix tab * Remove cpp patch since we don't need it * Revert 6b8759a860d5307a9ae31247eff3bce48f56aeaf Co-authored-by: JackBoosY <yuzaiyang@beyondsoft.com>
16 lines
509 B
Diff
16 lines
509 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index d145517..681b791 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -669,6 +669,10 @@ if (CYGWIN OR WIN32)
|
|
target_compile_definitions (glog PUBLIC GLOG_NO_ABBREVIATED_SEVERITIES)
|
|
endif (CYGWIN OR WIN32)
|
|
|
|
+if ((MSVC) AND (MSVC_VERSION GREATER_EQUAL 1914))
|
|
+ target_compile_options(glog INTERFACE "/Zc:__cplusplus")
|
|
+endif()
|
|
+
|
|
if (WITH_CUSTOM_PREFIX)
|
|
target_compile_definitions (glog PUBLIC GLOG_CUSTOM_PREFIX_SUPPORT)
|
|
endif (WITH_CUSTOM_PREFIX)
|