mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-01 13:37:55 +08:00
506299a173
* [libproxy]Add new port. * [libmodman]Add new port. * [libproxy]Support windows, set dependency libmodman. * Add usage, add vcpkg-cmake-wrapper.cmake to libproxy. * add empty line to usage. * [libmodman]Fix undefined typeid in Visual Studio 2019. * [libproxy]Fix install libproxy.py error when it not exist. * Disable arm/uwp build. * Enable static build on UNIX. * [libproxy]Re-generate patches, delete default feature tools and use system libmodman. * [libproxy]Disable install libproxy.py. * [libproxy]Disable install Libproxy.pm and PLlibproxy. * [libproxy]DISABLE PARALLEL CONFIGURE * [libproxy]Revert 6f233cced1a51a086e5fea5bf290565d9847d4b7 * [libmodman/libproxy]Fix arm build.
22 lines
864 B
Diff
22 lines
864 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 451e7a6..b6782fb 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -32,13 +32,15 @@ option(WITH_WEBKIT3 "Build against gtk-3 version of webkitgtk" OFF)
|
|
### Subdirectories
|
|
# Conditionally build bundled libmodman
|
|
option(FORCE_SYSTEM_LIBMODMAN "Force using system libmodman" OFF)
|
|
-find_package(libmodman QUIET)
|
|
+find_package(libmodman REQUIRED)
|
|
if(LIBMODMAN_FOUND)
|
|
if("${LIBMODMAN_VERSION_MAJOR}" STREQUAL "2")
|
|
message(STATUS "Building with system libmodman")
|
|
else()
|
|
message(FATAL_ERROR "Found incompatible libmodman on your system (libmodman 2.X is needed)")
|
|
endif()
|
|
+ include_directories(${LIBMODMAN_INCLUDE_DIR})
|
|
+ link_libraries(${LIBMODMAN_LIBRARIES})
|
|
else()
|
|
if(FORCE_SYSTEM_LIBMODMAN)
|
|
message(FATAL_ERROR "Libmodman could not be found on your system")
|