mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-27 10:21:07 +08:00
809e93f524
* Try to add libdwarf * Has * fix * hash * fixes * hash * Fixes * bump hash * zlib fix * bump hash * fix * bump hash * fixes * Bump hash * fix * bump * x * bump * fix * bump * fix * bump * fix * bump * fix * bump * fix * bump * Try this * bump * cleanup * bump * Update patches * bump hash * fix whitespace * bump * Update usage * Bump * Update portfile and patches (#1) * Re-introduce off_t patch * Bump * Fix patch * Bump * Usage is now correct * Bump * Revert "Usage is now correct" This reverts commit 54b32d172de8abd916589f781065c87d3afaaaf2. * Bump --------- Co-authored-by: Kai Pastor <dg0yt@darc.de>
25 lines
877 B
Diff
25 lines
877 B
Diff
diff --git a/src/bin/dwarfdump/CMakeLists.txt b/src/bin/dwarfdump/CMakeLists.txt
|
|
index 1b8aa3a..c77d2f0 100644
|
|
--- a/src/bin/dwarfdump/CMakeLists.txt
|
|
+++ b/src/bin/dwarfdump/CMakeLists.txt
|
|
@@ -66,7 +66,6 @@ target_compile_options(dwarfdump PRIVATE ${DW_FWALL})
|
|
target_link_libraries(dwarfdump PRIVATE ${dwarf-target} ${DW_FZLIB} ${DW_FZSTD} )
|
|
|
|
if(${CMAKE_SIZEOF_VOID_P} EQUAL 8)
|
|
- set(SUFFIX 64)
|
|
endif()
|
|
set(LIBDIR lib${SUFFIX})
|
|
set(BINDIR bin${SUFFIX})
|
|
diff --git a/src/lib/libdwarf/CMakeLists.txt b/src/lib/libdwarf/CMakeLists.txt
|
|
index 09908bb..91a1447 100644
|
|
--- a/src/lib/libdwarf/CMakeLists.txt
|
|
+++ b/src/lib/libdwarf/CMakeLists.txt
|
|
@@ -109,7 +109,6 @@ foreach(i RANGE ${targetCount})
|
|
|
|
set_target_properties(${target} PROPERTIES OUTPUT_NAME dwarf)
|
|
|
|
- set(SUFFIX $<$<EQUAL:${CMAKE_SIZEOF_VOID_P},8>:64>)
|
|
set(LIBDIR lib${SUFFIX})
|
|
set(BINDIR bin${SUFFIX})
|
|
|