mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-29 11:41:36 +08:00
506299a173
* [libproxy]Add new port. * [libmodman]Add new port. * [libproxy]Support windows, set dependency libmodman. * Add usage, add vcpkg-cmake-wrapper.cmake to libproxy. * add empty line to usage. * [libmodman]Fix undefined typeid in Visual Studio 2019. * [libproxy]Fix install libproxy.py error when it not exist. * Disable arm/uwp build. * Enable static build on UNIX. * [libproxy]Re-generate patches, delete default feature tools and use system libmodman. * [libproxy]Disable install libproxy.py. * [libproxy]Disable install Libproxy.pm and PLlibproxy. * [libproxy]DISABLE PARALLEL CONFIGURE * [libproxy]Revert 6f233cced1a51a086e5fea5bf290565d9847d4b7 * [libmodman/libproxy]Fix arm build.
28 lines
1.0 KiB
Diff
28 lines
1.0 KiB
Diff
diff --git a/libproxy/cmake/pxmodule.cmk b/libproxy/cmake/pxmodule.cmk
|
|
index bbbd989..956948a 100644
|
|
--- a/libproxy/cmake/pxmodule.cmk
|
|
+++ b/libproxy/cmake/pxmodule.cmk
|
|
@@ -20,7 +20,7 @@ function(px_module name build builtin)
|
|
add_library(${name} MODULE modules/${name}.cpp)
|
|
target_link_libraries(${name} libproxy)
|
|
set_target_properties(${name} PROPERTIES PREFIX "")
|
|
- install(TARGETS ${name} LIBRARY DESTINATION ${MODULE_INSTALL_DIR})
|
|
+ install(TARGETS ${name} LIBRARY DESTINATION tools)
|
|
if(${ARGC} GREATER 3)
|
|
target_link_libraries(${name} ${ARGN})
|
|
endif()
|
|
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
|
|
index 52010c6..0a3f4b5 100644
|
|
--- a/utils/CMakeLists.txt
|
|
+++ b/utils/CMakeLists.txt
|
|
@@ -1,5 +1,7 @@
|
|
include_directories("../libproxy")
|
|
|
|
+if (BUILD_TOOLS)
|
|
add_executable(proxy proxy.c)
|
|
target_link_libraries(proxy libproxy)
|
|
-install(TARGETS proxy RUNTIME DESTINATION ${BIN_INSTALL_DIR})
|
|
+install(TARGETS proxy RUNTIME DESTINATION tools)
|
|
+endif()
|
|
\ No newline at end of file
|