mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-02 22:35:31 +08:00
5898891125
* [openexr,openimageio,suitesparse,theia] updates for non-win32 * [theia] use only valid cmake symbols * [suitesparse] Fix build * [lapack] still not properly integrating with other ports * [lapack] intercept cmake module calls and substitute them with our defs * [suitesparse,clapack] fixes for proper integration * [ceres,clapack] bump CONTROL * [suitesparse] remove unnecessary defs * [clapack] improve wrapper logic * [WIN32] remove wrong symbol * [clapack] fix wrapper integration * [Accelerate] use best framework when available * [clapack] separate config from wrapper * [clapack] fix paths and filenames * [mlpack,armadillo,clapack] improve library handling * [mlpack] remove unnecessary cmake option * [clp,coinutils,osi,liblemon] dependencies of openmvg, improve compatibility with non-win32 * [openmvg] fix for case-sensitive filesystems * [clp,coinutils,osi] simplify CMakeLists removing many unnecessary steps * [sophus] Force rebuild * [theia] fixes for linux, part1 * [io2d] remove broken sintax * [fontconfig] bump version to remove CI cached failure * [theia] fixes for linux, part2 * [theia] remove unnecessary empty folders and comments from portfile * [theia] use correct build type removing forced vars in cmakelists.txt * [openmvg] add missing suitesparse target detection * [sophus] fix Suitesparse dependency * [sophus,openmvg] use suitesparse lowercase for module compatibility on case-sensitive filesystems * [suitesparse] fixes for case-sensitive filesystems * [openmvg] use correct Eigen3 name for case-sensitive filesystems * [sophus] trigger rebuild * [shogun] use modern vcpkg style * [shogun] add missing cmake system processor symbol
23 lines
890 B
Diff
23 lines
890 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 6f97c8b..a10b599 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -145,7 +145,7 @@ ENDIF()
|
|
DetectSystemName()
|
|
|
|
# Get processor type, sets MACHINE macro
|
|
-SET(MACHINE ${CMAKE_SYSTEM_PROCESSOR})
|
|
+add_definitions(-DMACHINE=${CMAKE_SYSTEM_PROCESSOR})
|
|
|
|
SET(EXT_LIB_SWIG_RUBY ".so")
|
|
if(DARWIN)
|
|
@@ -174,7 +174,7 @@ ENDIF()
|
|
|
|
IF(CMAKE_COMPILER_IS_GNUCXX)
|
|
SET(RELEASE_COMPILER_FLAGS "-fexpensive-optimizations -frerun-cse-after-loop -fcse-follow-jumps -finline-functions -fschedule-insns2 -fthread-jumps -fforce-addr -fstrength-reduce -funroll-loops")
|
|
- IF (${MACHINE} MATCHES "x86_64" OR ${MACHINE} MATCHES "i686")
|
|
+ IF (CMAKE_SYSTEM_PROCESSOR MATCHES "x86_64" OR CMAKE_SYSTEM_PROCESSOR MATCHES "i686")
|
|
SET(RELEASE_COMPILER_FLAGS "${RELEASE_COMPILER_FLAGS} -mfpmath=sse")
|
|
ENDIF()
|
|
ELSEIF(${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang")
|