vcpkg/ports/opencolorio/fix-buildTools.patch
LilyWangLL bfc00415da
[opencolorio] Fix tools build error (#23408)
* [opencolorio] Fix tools build error

* update license

* update version

Co-authored-by: Lily Wang <v-lilywang@microsoft.com>
2022-03-07 11:06:01 -08:00

14 lines
399 B
Diff

diff --git a/src/OpenColorIO/CMakeLists.txt b/src/OpenColorIO/CMakeLists.txt
index b992bbc..804d3c5 100644
--- a/src/OpenColorIO/CMakeLists.txt
+++ b/src/OpenColorIO/CMakeLists.txt
@@ -248,7 +248,7 @@ if(NOT BUILD_SHARED_LIBS)
else()
# Only exports selected symbols.
target_compile_definitions(OpenColorIO
- PUBLIC
+ PRIVATE
OpenColorIO_EXPORTS
)
endif()