mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-01 21:58:55 +08:00
fa1823dcad
* [opencolorio-tools] Separate feature application to avoid circular dependency * [opencolorio] Remove oiio related patch * [opencolorio] Do not make tools * [opencolorio-tools] make sure share folder is clean * [docs] Add format document * improve the error message * Check the error message * Finish test * Update ports/opencolorio/portfile.cmake Co-authored-by: ras0219 <533828+ras0219@users.noreply.github.com> * Use vcpkg_copy_tools Co-authored-by: ras0219 <533828+ras0219@users.noreply.github.com>
15 lines
497 B
Diff
15 lines
497 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 5cfa601..f79807c 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -475,7 +475,8 @@ endif()
|
|
if(OCIO_BUILD_APPS AND (OCIO_BUILD_STATIC OR OCIO_BUILD_SHARED) )
|
|
|
|
# Try to find OpenImageIO (OIIO) and OpenGL stuff
|
|
- OCIOFindOpenImageIO()
|
|
+ find_package(OpenImageIO CONFIG REQUIRED)
|
|
+ set(OIIO_LIBRARIES OpenImageIO::OpenImageIO OpenImageIO::OpenImageIO_Util)
|
|
|
|
if(OIIO_FOUND)
|
|
add_subdirectory(src/apps/ocioconvert)
|