mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-30 20:59:12 +08:00
5eae23f558
* [azure-kinect-sensor-sdk] fix linux build and other issues - linux: warnings stopping the build - linux: set correct casing for dependecies - linux: depthengine - upgrade to 1.4.1 * Update ports/azure-kinect-sensor-sdk/CONTROL * Update ports/azure-kinect-sensor-sdk/portfile.cmake * Force to re-download archive, revert 9cd44db8e32939fa6f5fa4c2166d32d3ce63ff16 * update version record * Update ports/azure-kinect-sensor-sdk/CONTROL * Update versions/a-/azure-kinect-sensor-sdk.json Co-authored-by: Jack·Boos·Yu <47264268+JackBoosY@users.noreply.github.com> Co-authored-by: JackBoosY <yuzaiyang@beyondsoft.com> Co-authored-by: Robert Schumacher <roschuma@microsoft.com>
14 lines
481 B
Diff
14 lines
481 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 58a092e..ed4a6d2 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -107,6 +107,7 @@ find_package(EBML CONFIG REQUIRED)
|
|
find_package(JPEG REQUIRED)
|
|
find_library(JPEG_TURBO turbojpeg REQUIRED)
|
|
find_package(Matroska CONFIG REQUIRED)
|
|
+add_definitions(-DMATROSKA_VERSION=2)
|
|
find_package(libsoundio CONFIG REQUIRED)
|
|
find_package(libusb CONFIG REQUIRED)
|
|
find_package(libuvc CONFIG REQUIRED)
|
|
find_package(libyuv CONFIG REQUIRED)
|