mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-28 19:25:27 +08:00
d8c61f7fbf
* [onnx] feature: foxi * https://github.com/houseroad/foxi * install the project's copyright (MIT) * pytorch requires `foxi_loader` The CMake target will be renamed to `onnxifi_*` for convenience. * [onnx] force onnx/onnx_proto static in Windows Checked the protject's CI logs. It turned out onnx/onnx_proto are ALWAYS static. Specify it in CMakeLists.txt because vcpkg configures `BUILD_SHARED_LIBS=ON` If the triplet requires it. There are no `ONNXIFI_ENABLE_EXT=ON` case. Removed the misused build options in portfile. Add port feature `protobuf-lite` which is in build option. * [onnx] support windows static triplets * remove SHARED for `onnxifi_wrapper` and `onnxifi_dummy` * [onnx] fix wrong LICENSE install * [onnx] remove feature 'foxi' * also remove redundant part in patch files * [libtorch] rework patch files * [libtorch] config fixup ATen, Torch * use `link_libraries` to vcpkg installed folder * future work may use library names without `find_library` * update versions JSON to use `version-semver` * [libtorch] make shared only * Caffe2 is exported when BUILD_SHARED_LIBS * [libtorch] remove headers after install * [libtorch] rewrite patches and feature options * checked osx / linux build * [libtorch] use eigen3 always * Caffe2 eigen_utils.h requires it * [libtorch] error if BLAS feature collision * [libtorch] remove !static * [libtorch] replace vcpkg_find_acquire_program * let's see python3 from find_program supports * Dependency python3 * [libtorch] migrate works from luncliff/vcpkg-registry * Update target version and dependencies * Removed unsupported features * [libtorch] misc fix, update version, baseline * fix merge confict for 'onnx' * [libtorch] install pip packages * typing-extensions, pyyaml * [libtorch] turn off Metal options * [onnx] revert 'onnx' changes * [libtorch] refine patches * [libtorch] link with foxi_loader * removed wrong onnx related source changes * [libtorch] update git-tree * [libtorch] reduce patch size * [libtorch] find numa and activate USE_NUMA * Update ports/libtorch/portfile.cmake Co-authored-by: nicole mazzuca <83086508+strega-nil-ms@users.noreply.github.com> * Update ports/libtorch/portfile.cmake Co-authored-by: nicole mazzuca <83086508+strega-nil-ms@users.noreply.github.com> * Update ports/libtorch/portfile.cmake Co-authored-by: nicole mazzuca <83086508+strega-nil-ms@users.noreply.github.com> * [libtorch] fix mistype and update version JSON * Add double quotes * version * Fix support expression * version * [libtorch] update cpuinfo usage * https://github.com/microsoft/vcpkg/pull/23944 * update version * [tensorpipe] fix linux install * find_package(Tensorpipe) may fail because of case mismatch * [tensorpipe] update versions JSON * [libtorch] fix feature failures * [libtorch] remove CUDA feature * [libtorch] giveup 'fbgemm' feature * [libtorch] use mpi, openmpi in Linux * [libtorch] fix glog link error * [tensorpipe] bump port version * see https://github.com/microsoft/vcpkg/pull/23569 * [libtorch] fix patch list * [libtorch] use official libuv config * see https://github.com/microsoft/vcpkg/pull/24745 * Update ports/libtorch/portfile.cmake Co-authored-by: Jack·Boos·Yu <47264268+JackBoosY@users.noreply.github.com> * Update ports/libtorch/portfile.cmake Co-authored-by: Jack·Boos·Yu <47264268+JackBoosY@users.noreply.github.com> * update versions JSON * revert unnecessary 'nnpack' changes * Update ports/libtorch/portfile.cmake Co-authored-by: Adam Johnson <AdamJohnso@gmail.com> * [libtorch] use vcpkg-get-python-packages * [libtorch] provide path of python3 * Update ports/libtorch/portfile.cmake Co-authored-by: Billy O'Neal <bion@microsoft.com> * Fix version database. * [libtorch] use openmpi in linux/osx * [libtorch] update to v1.12.1 * [libtorch] find_program(python3, python) * [libtorch] provide PYTHON_EXECUTABLE directly * [xnnpack] update to 2022-02-17 * [xnnpack] use C11, C++11 * [libtorch] more patches, DISABLE_PARALLEL_CONFIGURE * [libtorch] allow static torch_cpu build * Revert "[libtorch] allow static torch_cpu build" This reverts commit 5fd4ef0bbe4f56d5c027494c7c571a4f13b37b25. * [libtorch] find_package(BLAS) * [libtorch] simplify Python3, NumPy option use * [libtorch] fix install in Windows * [libtorch] exclude torch_global_deps in Windows * [libtorch] platform of nnpack feature * [libtorch] fix MPI option in Windows * [libtorch] fixing LNK1161 * [libtorch] fix some mistypes * [libtorch] define NOMINMAX for c10 * [libtorch] disable vulkan feature in Windows * ci.baseline.txt: allow libtorch failure * fails with Visual Studio 2022 17.4.2 * requires 17.4.3+ * Enable testing port on Windows * [caffe2] redirect to libtorch * update baseline Co-authored-by: JackBoosY <yuzaiyang@beyondsoft.com> Co-authored-by: nicole mazzuca <83086508+strega-nil-ms@users.noreply.github.com> Co-authored-by: Billy Robert O'Neal <bion@microsoft.com> Co-authored-by: Jack·Boos·Yu <47264268+JackBoosY@users.noreply.github.com> Co-authored-by: Adam Johnson <AdamJohnso@gmail.com> Co-authored-by: Victor Romero <romerosanchezv@gmail.com>
117 lines
4.7 KiB
Diff
117 lines
4.7 KiB
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 2ca06ee..b0d8873 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -6526,7 +6526,7 @@ ELSE()
|
|
SET_PROPERTY(SOURCE ${COLD_SRCS} APPEND_STRING PROPERTY COMPILE_FLAGS "$<$<NOT:$<CONFIG:Debug>>: -Os >")
|
|
ENDIF()
|
|
|
|
-TARGET_INCLUDE_DIRECTORIES(XNNPACK PUBLIC include)
|
|
+TARGET_INCLUDE_DIRECTORIES(XNNPACK PUBLIC $<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}/include> $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>)
|
|
TARGET_INCLUDE_DIRECTORIES(XNNPACK PRIVATE src)
|
|
TARGET_INCLUDE_DIRECTORIES(all_microkernels PRIVATE include src)
|
|
TARGET_INCLUDE_DIRECTORIES(packing PRIVATE include src)
|
|
@@ -6547,7 +6547,7 @@ IF(LIBM)
|
|
ENDIF()
|
|
|
|
# ---[ Configure clog
|
|
-IF(NOT TARGET clog)
|
|
+IF(FALSE)
|
|
IF(NOT XNNPACK_USE_SYSTEM_LIBS)
|
|
SET(CLOG_BUILD_TESTS OFF CACHE BOOL "")
|
|
SET(CLOG_RUNTIME_TYPE "${CPUINFO_RUNTIME_TYPE}" CACHE STRING "")
|
|
@@ -6565,11 +6565,9 @@ IF(NOT TARGET clog)
|
|
SET_PROPERTY(TARGET clog PROPERTY IMPORTED_LOCATION "${CLOG_LIBRARY}")
|
|
ENDIF()
|
|
ENDIF()
|
|
-TARGET_LINK_LIBRARIES(XNNPACK PRIVATE clog)
|
|
-TARGET_LINK_LIBRARIES(jit PRIVATE clog)
|
|
|
|
# ---[ Configure cpuinfo
|
|
-IF(NOT TARGET cpuinfo)
|
|
+IF(false)
|
|
IF(NOT XNNPACK_USE_SYSTEM_LIBS)
|
|
SET(CPUINFO_BUILD_TOOLS OFF CACHE BOOL "")
|
|
SET(CPUINFO_BUILD_UNIT_TESTS OFF CACHE BOOL "")
|
|
@@ -6587,10 +6585,12 @@ IF(NOT TARGET cpuinfo)
|
|
SET_PROPERTY(TARGET cpuinfo PROPERTY IMPORTED_LOCATION "${CPUINFO_LIBRARY}")
|
|
ENDIF()
|
|
ENDIF()
|
|
-TARGET_LINK_LIBRARIES(XNNPACK PRIVATE cpuinfo)
|
|
+find_package(cpuinfo CONFIG REQUIRED)
|
|
+TARGET_LINK_LIBRARIES(XNNPACK PRIVATE cpuinfo::clog cpuinfo::cpuinfo)
|
|
+TARGET_LINK_LIBRARIES(jit PRIVATE cpuinfo::clog)
|
|
|
|
# ---[ Configure pthreadpool
|
|
-IF(NOT TARGET pthreadpool)
|
|
+IF(FALSE)
|
|
IF(NOT XNNPACK_USE_SYSTEM_LIBS)
|
|
SET(PTHREADPOOL_BUILD_TESTS OFF CACHE BOOL "")
|
|
SET(PTHREADPOOL_BUILD_BENCHMARKS OFF CACHE BOOL "")
|
|
@@ -6607,14 +6607,15 @@ IF(NOT TARGET pthreadpool)
|
|
SET_PROPERTY(TARGET pthreadpool PROPERTY IMPORTED_LOCATION "${PTHREADPOOL_LIBRARY}")
|
|
ENDIF()
|
|
ENDIF()
|
|
-TARGET_LINK_LIBRARIES(XNNPACK PUBLIC pthreadpool)
|
|
-TARGET_LINK_LIBRARIES(all_microkernels PRIVATE pthreadpool)
|
|
-TARGET_LINK_LIBRARIES(indirection PRIVATE pthreadpool)
|
|
-TARGET_LINK_LIBRARIES(jit PRIVATE pthreadpool)
|
|
-TARGET_LINK_LIBRARIES(packing PRIVATE pthreadpool)
|
|
+find_package(unofficial-pthreadpool CONFIG REQUIRED)
|
|
+target_link_libraries(XNNPACK PUBLIC unofficial::pthreadpool)
|
|
+target_link_libraries(all_microkernels PRIVATE unofficial::pthreadpool)
|
|
+target_link_libraries(indirection PRIVATE unofficial::pthreadpool)
|
|
+target_link_libraries(jit PRIVATE unofficial::pthreadpool)
|
|
+target_link_libraries(packing PRIVATE unofficial::pthreadpool)
|
|
|
|
# ---[ Configure FXdiv
|
|
-IF(NOT TARGET fxdiv)
|
|
+IF(FALSE)
|
|
IF(NOT XNNPACK_USE_SYSTEM_LIBS)
|
|
SET(FXDIV_BUILD_TESTS OFF CACHE BOOL "")
|
|
SET(FXDIV_BUILD_BENCHMARKS OFF CACHE BOOL "")
|
|
@@ -6630,12 +6631,13 @@ IF(NOT TARGET fxdiv)
|
|
SET_PROPERTY(TARGET fxdiv PROPERTY LINKER_LANGUAGE C)
|
|
ENDIF()
|
|
ENDIF()
|
|
-TARGET_LINK_LIBRARIES(XNNPACK PRIVATE fxdiv)
|
|
-TARGET_LINK_LIBRARIES(all_microkernels PRIVATE fxdiv)
|
|
-TARGET_LINK_LIBRARIES(indirection PRIVATE fxdiv)
|
|
+find_path(FXDIV_INCLUDE_DIRS "fxdiv.h" REQUIRED)
|
|
+target_include_directories(XNNPACK PRIVATE ${FXDIV_INCLUDE_DIRS})
|
|
+target_include_directories(all_microkernels PRIVATE ${FXDIV_INCLUDE_DIRS})
|
|
+target_include_directories(indirection PRIVATE ${FXDIV_INCLUDE_DIRS})
|
|
|
|
# ---[ Configure FP16
|
|
-IF(NOT TARGET fp16)
|
|
+IF(FALSE)
|
|
IF(NOT XNNPACK_USE_SYSTEM_LIBS)
|
|
SET(FP16_BUILD_TESTS OFF CACHE BOOL "")
|
|
SET(FP16_BUILD_BENCHMARKS OFF CACHE BOOL "")
|
|
@@ -6651,15 +6653,21 @@ IF(NOT TARGET fp16)
|
|
SET_PROPERTY(TARGET fp16 PROPERTY LINKER_LANGUAGE C)
|
|
ENDIF()
|
|
ENDIF()
|
|
-TARGET_LINK_LIBRARIES(XNNPACK PRIVATE fp16)
|
|
-TARGET_LINK_LIBRARIES(all_microkernels PRIVATE fp16)
|
|
-TARGET_LINK_LIBRARIES(packing PRIVATE fp16)
|
|
-TARGET_LINK_LIBRARIES(indirection PRIVATE fp16)
|
|
+find_path(FP16_INCLUDE_DIRS "fp16.h" REQUIRED)
|
|
+target_include_directories(XNNPACK PRIVATE ${FP16_INCLUDE_DIRS})
|
|
+target_include_directories(all_microkernels PRIVATE ${FP16_INCLUDE_DIRS})
|
|
+target_include_directories(packing PRIVATE ${FP16_INCLUDE_DIRS})
|
|
+target_include_directories(indirection PRIVATE ${FP16_INCLUDE_DIRS})
|
|
|
|
INSTALL(TARGETS XNNPACK
|
|
+ EXPORT xnnpack-config
|
|
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
|
|
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
|
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
|
PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
|
|
+install(EXPORT xnnpack-config
|
|
+ NAMESPACE unofficial::
|
|
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/xnnpack)
|
|
|
|
# ---[ XNNPACK unit tests
|
|
IF(XNNPACK_BUILD_TESTS)
|