mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-28 19:25:27 +08:00
86ff75c6d8
* [glog] fix not work on c++03 * remove NOMINMAX * Revert "remove NOMINMAX" This reverts commit 17a80f259dd2718a375d06c0686f69c647cf2d57. * fix atomic * remove nominmax * CI [skip actions]
18 lines
393 B
Diff
18 lines
393 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 13c474b..7858c8f 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -398,6 +398,12 @@ if (HAVE_EXECINFO_H)
|
|
set (HAVE_STACKTRACE 1)
|
|
endif (HAVE_EXECINFO_H)
|
|
|
|
+if (HAVE_CXX11_ATOMIC)
|
|
+ set (ac_cv_cxx11_atomic 1)
|
|
+else ()
|
|
+ set (ac_cv_cxx11_atomic 0)
|
|
+endif ()
|
|
+
|
|
if (WITH_SYMBOLIZE)
|
|
if (WIN32 OR CYGWIN)
|
|
if(CMAKE_CROSSCOMPILING)
|