vcpkg/ports/expat/fix-find-package-by-cmake.patch
NancyLi1013 d6285bc24b
[expat] Update the version to 2.2.9 (add support for uwp) (#9146)
* [expat] Update the version to 2.2.9(support uwp)

* [readosm] Fix expat.lib cannot be found

* Remove expat:arm-uwp and expat:x64-uwp from fail list in ci.baseline.txt

* [apr-util,io2d,skia] Fix expat cannot be found and also update expat

* [many ports] Add supports and fix the regressions

* Fix new regressions

* Fix typo

* [io2d] Update expat patch

* [io2d,libkml,skia] Fix expat cannot find and also fix typo

* [expat] Remove usage

* [libkml,vtk] Update expat patch and fix static build

* [wxwidgets] Fix static build caused by expat cannot found

* Update as review suggestion

* Add Port-Version

* Remove evpp:x64-osx=fail from ci.baseline.txt

* [wxwidgest] Remove unnecessary spaces

* [itk] Fix expat cannot be found

* fix cmake test port

* [wxwidgets] Update Port-Version

Co-authored-by: Nicole Mazzuca <mazzucan@outlook.com>
2020-08-17 08:33:44 -07:00

41 lines
1.3 KiB
Diff

diff --git a/expat/CMakeLists.txt b/expat/CMakeLists.txt
index 2084424..f3b9207 100644
--- a/expat/CMakeLists.txt
+++ b/expat/CMakeLists.txt
@@ -269,6 +269,10 @@ if(EXPAT_WITH_LIBBSD)
target_link_libraries(${_EXPAT_TARGET} ${LIB_BSD})
endif()
+target_include_directories(${_EXPAT_TARGET} INTERFACE
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/include>
+ $<INSTALL_INTERFACE:include>)
+
set(LIBCURRENT 7) # sync
set(LIBREVISION 11) # with
set(LIBAGE 6) # configure.ac!
@@ -490,7 +494,7 @@ configure_package_config_file(
cmake/expat-config.cmake.in
cmake/expat-config.cmake
INSTALL_DESTINATION
- ${CMAKE_INSTALL_LIBDIR}/cmake/expat-${PROJECT_VERSION}/
+ ${CMAKE_INSTALL_LIBDIR}/cmake/expat/
)
write_basic_package_version_file(
cmake/expat-config-version.cmake
@@ -507,13 +511,13 @@ expat_install(
${CMAKE_CURRENT_BINARY_DIR}/cmake/expat-config.cmake
${CMAKE_CURRENT_BINARY_DIR}/cmake/expat-config-version.cmake
DESTINATION
- ${CMAKE_INSTALL_LIBDIR}/cmake/expat-${PROJECT_VERSION}/
+ ${CMAKE_INSTALL_LIBDIR}/cmake/expat/
)
expat_install(
EXPORT
expat
DESTINATION
- ${CMAKE_INSTALL_LIBDIR}/cmake/expat-${PROJECT_VERSION}/
+ ${CMAKE_INSTALL_LIBDIR}/cmake/expat/
NAMESPACE
expat::
)