mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-29 11:41:36 +08:00
078f136afc
* glog upgrade * tmp * is glog initialized * fix glog dependency * fix glog dependency * fix folly abort call * delete buildtrees * fix folly abort call * delete useless lines * fix caffe2 isglog initialized * make patches shorter * glog fix typo * glog fix tab * Remove cpp patch since we don't need it * Revert 6b8759a860d5307a9ae31247eff3bce48f56aeaf Co-authored-by: JackBoosY <yuzaiyang@beyondsoft.com>
23 lines
531 B
Diff
23 lines
531 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index d314abe..d145517 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -450,6 +450,9 @@ endif (HAVE_CXX11_ATOMIC)
|
|
|
|
if (WITH_SYMBOLIZE)
|
|
if (WIN32 OR CYGWIN)
|
|
+ if(CMAKE_CROSSCOMPILING)
|
|
+ set(HAVE_SYMBOLIZE 0)
|
|
+ else()
|
|
cmake_push_check_state (RESET)
|
|
set (CMAKE_REQUIRED_LIBRARIES DbgHelp)
|
|
|
|
@@ -480,6 +483,7 @@ if (WITH_SYMBOLIZE)
|
|
]=] HAVE_SYMBOLIZE)
|
|
|
|
cmake_pop_check_state ()
|
|
+ endif()
|
|
|
|
if (HAVE_SYMBOLIZE)
|
|
set (HAVE_STACKTRACE 1)
|