mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-28 19:25:27 +08:00
ec80d1c5dc
* [vlpp] Fix configure issues, export unofficial target * version * Update to latest, add features, force static only * patch format * FIx feature option pos * typo * Remove source_group since it's no longer an interface library, fix remove code * Drop support with uwp since port uses desktop app only api * Drop support with osx, add system-related definitions * Revert c7ba8be6d8e9dc13931215f6b36923128916f39f * correct relationship, add and modify features * Remove double quotes, fix extra_includes * fix installation * Fix arm build, switch tool build to cmake * Use official fix to fix arm issue * update to latest to fix arm regression * Update to latest * Set to interface library * version * Update to latest * version * Apply suggestions * version * Update ref * version * official target * version
25 lines
886 B
Diff
25 lines
886 B
Diff
diff --git a/Import/CMakeLists.txt b/Import/CMakeLists.txt
|
|
index c65ab65..2101e86 100644
|
|
--- a/Import/CMakeLists.txt
|
|
+++ b/Import/CMakeLists.txt
|
|
@@ -10,6 +10,7 @@ cmake_dependent_option(WORKFLOW_COMPILER "Use VlppWorkflowCompiler" ON "WORKFLOW
|
|
cmake_dependent_option(GACUI_CORE "Use GacUI" ON "GLR_PARSER;WORKFLOW_LIBRARY" OFF)
|
|
cmake_dependent_option(GACUI_REFLECTION "Use GacUIReflection" ON "GACUI_CORE;WORKFLOW_RUNTIME;REFLECTION" OFF)
|
|
cmake_dependent_option(GACUI_COMPILER "Use GacUICompiler" ON "GACUI_REFLECTION;WORKFLOW_COMPILER" OFF)
|
|
+option(BUILD_TOOLS "Build tools" OFF)
|
|
|
|
# core library
|
|
set(CORE_HDRS
|
|
@@ -144,6 +145,11 @@ if (GACUI_CORE)
|
|
list(APPEND EXPORT_TARGETS gacui_core)
|
|
endif()
|
|
|
|
+if (BUILD_TOOLS)
|
|
+ add_subdirectory(gacgen/Tools/GacGen)
|
|
+ add_subdirectory(workflow/Tools/CppMerge)
|
|
+endif()
|
|
+
|
|
# Install targets
|
|
install(
|
|
TARGETS ${EXPORT_TARGETS}
|