mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-28 03:10:57 +08:00
14 lines
525 B
Diff
14 lines
525 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index d3fbad30..9cf01cf5 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -89,7 +89,7 @@ include(cmakescripts/PackageInfo.cmake)
|
|
|
|
# Detect CPU type and whether we're building 64-bit or 32-bit code
|
|
math(EXPR BITS "${CMAKE_SIZEOF_VOID_P} * 8")
|
|
-string(TOLOWER ${CMAKE_SYSTEM_PROCESSOR} CMAKE_SYSTEM_PROCESSOR_LC)
|
|
+string(TOLOWER "${CMAKE_SYSTEM_PROCESSOR}" CMAKE_SYSTEM_PROCESSOR_LC)
|
|
set(COUNT 1)
|
|
foreach(ARCH ${CMAKE_OSX_ARCHITECTURES})
|
|
if(COUNT GREATER 1)
|