mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-28 19:25:27 +08:00
9172179c51
* [gstreamer] create port with meson * initial build config * nodownload in vcpkg_configure_meson needs be removed * [gstreamer] remove duplicated GL headers * 1st check for deps in windows * mac: fix regex for bison * [gstreamer] more detailed options * remove glib usage Will use WIP changes in microsoft/vcpkg * [gstreamer] build with glib port * [gstreamer] extract plugins to features * fix some config errors in windows * fails to find z.lib. this should be zlib.lib * [gstreamer] create patches to search 'zlib' * update tool list * [vcpkg meson] add path of GIT * use append for LINKER_FLAGS Allow injection of LINKER_FLAGS to vcpkg_configure_meson * [gstreamer] update baseline and port SHA * [gstreamer] zlib is required for Windows * Revert "[vcpkg meson] add path of GIT" This reverts commit 8a67fbd1d287fa769cf516b834981ea175463492. * [gstreamer] make git visible in meson * [gstreamer] fix platform expression * [gstreamer] revert change of vcpkg_configure_meson * [gstreamer] modify build.ninja after configure * [gstreamer] drop unknown flag with vcpkg_replace_string * [gstreamer] disable 'devtools' option * [gstreamer] remove dylib * [gstreamer] move dll,pdb after install * [gstreamer] remove 'nls' feature Co-authored-by: Billy Robert ONeal III <bion@microsoft.com>
14 lines
560 B
Diff
14 lines
560 B
Diff
diff --git a/gst-libs/gst/tag/meson.build b/gst-libs/gst/tag/meson.build
|
|
index 5ec3739..a6cff8d 100644
|
|
--- a/gst-libs/gst/tag/meson.build
|
|
+++ b/gst-libs/gst/tag/meson.build
|
|
@@ -70,7 +70,7 @@ endif
|
|
core_conf.set('HAVE_ISO_CODES', have_iso_codes)
|
|
|
|
# could drop optional zlib dep and use g_zlib_decompressor_new()
|
|
-zlib_dep = dependency('zlib', required : false)
|
|
+zlib_dep = dependency('zlib', required : true)
|
|
if not zlib_dep.found()
|
|
zlib_dep = cc.find_library('z', required : false)
|
|
if not zlib_dep.found() or not cc.has_header('zlib.h')
|