mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-02 22:35:31 +08:00
fc0d6b2800
* [dav1d] Add dav1d AV1 decoder port * Remove unnecessary port-version Co-authored-by: NancyLi1013 <46708020+NancyLi1013@users.noreply.github.com> * Bump dav1d to 0.8.1 * Skip dav1d x86 due to infinite link * Add dav1d port version * Apply dav1d code review * Reset dav1d version Co-authored-by: NancyLi1013 <46708020+NancyLi1013@users.noreply.github.com>
14 lines
433 B
Diff
14 lines
433 B
Diff
diff --git a/meson.build b/meson.build
|
|
index 07b2586..02acd91 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -370,7 +370,7 @@ endif
|
|
|
|
cdata.set10('ARCH_PPC64LE', host_machine.cpu() == 'ppc64le')
|
|
|
|
-if cc.symbols_have_underscore_prefix()
|
|
+if cc.symbols_have_underscore_prefix() or (host_machine.cpu_family() == 'x86' and host_machine.system() == 'windows')
|
|
cdata.set10('PREFIX', true)
|
|
cdata_asm.set10('PREFIX', true)
|
|
endif
|