mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-17 23:08:18 +08:00
0d27810d17
* Revise portfile * Plugins are a default feature; fix disabling * Remove line continuations from pc file vcpkg_fixup_pkgconfig cannot handle it. * Control nvtt plugin via feature * Control dae plugin, not find_package * Control fontconfig via feature Use CMake's (3.14) find module for which vcpkg provides a wrapper. OSG links to Fontconfig::Fontconfig. OSG default is to use Fontconfig except for ios and android. * Control freetype via feature Use CMake's find module for which vcpkg provides a wrapper. OSG links to FREETYPE_LIBRARIES. * Control RestHttpDevice via feature Only this plugin needs boost. * Drop unused liblas dependency * Drop unused coin dependency Coin was meant to be used for the inventor plugin, but this plugin is disabled. * Control sdl1 via feature * Enable apps on linux * Disable apps and docs for debug * Drop example application patch * Use option, not patch, to disable DLL versioning * Fix osg plugin PDB installation * Prefer <Pkg>_LIBRARIES for linking <Pkg>_LIBRARIES carries debug+release config and transitive usage requirements. * Curl patches are obsolete now. We leverage CURL_LIBRARIES via link-libraries.patch. * Add unofficial config export * Use toolchain's windows version Fixes mingw build. * Avoid extra dependency lookups * Silence warnings about plugin control variables * Define OSG_LIBRARY_STATIC * Revise copying of plugins * Control OpenEXR via feature Unblock uwp. * Allow jasper without opengl * [osgearth] Remove obsolete geos patching The build uses exported geos config. * [osgearth] Serialize linking to avoid OOM errors * [osgearth] Fix minor portfile issues * [osgearth] Prefer <Pkg>_LIBRARIES for linking <Pkg>_LIBRARIES carries debug+release config and transitive usage requirements. * [osgearth] Use unofficial osg config * [osgearth] Fix lib installation dir * [osgearth] Revise OSGEARTH_LIBRARY_STATIC * [osgearth] Revise find_package patching * [osgearth] Revise copying of plugins * [osgearth] Disable tools for debug variant * [osgearth] Control Blend2D via feature * Update versions * Fix plugin lookup * Update versions * CR request * Update versions * [osgearth] Remove tools from default features * Update versions
26 lines
968 B
Diff
26 lines
968 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index bf8971b..242f412 100755
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -143,7 +144,19 @@ if(GIT_FOUND AND EXISTS "${PROJECT_SOURCE_DIR}/.git")
|
|
ENDIF (OSGEARTH_USE_GLES)
|
|
|
|
# required
|
|
-find_package(OSG REQUIRED)
|
|
+find_package(OSG NAMES unofficial-osg)
|
|
+find_path(OSG_INCLUDE_DIR osg/Version) # For detecting the version and setting the plugin path
|
|
+set(OSG_INCLUDE_DIRS "")
|
|
+set(OSG_LIBRARY unofficial::osg::osg)
|
|
+set(OSGUTIL_LIBRARY unofficial::osg::osgUtil)
|
|
+set(OSGDB_LIBRARY unofficial::osg::osgDB)
|
|
+set(OSGTEXT_LIBRARY unofficial::osg::osgText)
|
|
+set(OSGSIM_LIBRARY unofficial::osg::osgSim)
|
|
+set(OSGVIEWER_LIBRARY unofficial::osg::osgViewer)
|
|
+set(OSGGA_LIBRARY unofficial::osg::osgViewer)
|
|
+set(OSGSHADOW_LIBRARY unofficial::osg::osgShadow)
|
|
+set(OSGMANIPULATOR_LIBRARY unofficial::osg::osgManipulator)
|
|
+set(OPENTHREADS_LIBRARY unofficial::osg::OpenThreads)
|
|
find_package(CURL REQUIRED)
|
|
find_package(GDAL REQUIRED)
|
|
|