mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-28 19:25:27 +08:00
297ff7ba3e
* Consolidate netcdf-c ZLIB patching * Update to 4.8.1, refresh patches * Resolve parameter warning * Decouple netcdf-4 feature from hdf5 * Expose NCZarr features * Break vcpkg CI cascade * Fix hdf5 szip support detection for static linkage * Allow curl, hdf5, libzip with minimal dependencies * Disable fatal warnings on uwp * Update versions * Fix libzip dependency * Fix and simplify szip config patch * Revert nczarr-s3 feature for now * Update versions * [skip actions] CI * [skip actions] Debug ci failure * Revert "[skip actions] Debug ci failure" This reverts commit 03f3d52623026e9f16f8be067a07499aa5788b55.
20 lines
572 B
Diff
20 lines
572 B
Diff
diff --git a/liblib/CMakeLists.txt b/liblib/CMakeLists.txt
|
|
index 9e126ec..1363d35 100644
|
|
--- a/liblib/CMakeLists.txt
|
|
+++ b/liblib/CMakeLists.txt
|
|
@@ -79,8 +79,14 @@ ENDIF()
|
|
IF(USE_HDF5)
|
|
if(TARGET hdf5::hdf5-shared)
|
|
SET(TLL_LIBS ${TLL_LIBS} hdf5::hdf5-shared hdf5::hdf5_hl-shared)
|
|
+ if(USE_PARALLEL)
|
|
+ list(APPEND TLL_LIBS ${MPI_C_LIBRARIES})
|
|
+ endif()
|
|
else()
|
|
SET(TLL_LIBS ${TLL_LIBS} hdf5::hdf5-static hdf5::hdf5_hl-static)
|
|
+ if(USE_PARALLEL)
|
|
+ list(APPEND TLL_LIBS ${MPI_C_LIBRARIES})
|
|
+ endif()
|
|
endif()
|
|
elseif(0)
|
|
IF(NOT MSVC)
|