mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-28 19:25:27 +08:00
297ff7ba3e
* Consolidate netcdf-c ZLIB patching * Update to 4.8.1, refresh patches * Resolve parameter warning * Decouple netcdf-4 feature from hdf5 * Expose NCZarr features * Break vcpkg CI cascade * Fix hdf5 szip support detection for static linkage * Allow curl, hdf5, libzip with minimal dependencies * Disable fatal warnings on uwp * Update versions * Fix libzip dependency * Fix and simplify szip config patch * Revert nczarr-s3 feature for now * Update versions * [skip actions] CI * [skip actions] Debug ci failure * Revert "[skip actions] Debug ci failure" This reverts commit 03f3d52623026e9f16f8be067a07499aa5788b55.
35 lines
1.0 KiB
Diff
35 lines
1.0 KiB
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index b93a141..c3763a7 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -957,7 +957,14 @@ OPTION(ENABLE_DAP_REMOTE_TESTS "Enable DAP remote tests." ON)
|
|
SET(REMOTETESTSERVERS "remotetest.unidata.ucar.edu" CACHE STRING "test servers to use for remote test")
|
|
|
|
# See if we have libzip
|
|
-FIND_PACKAGE(Zip)
|
|
+if(ENABLE_NCZARR_ZIP)
|
|
+ find_package(libzip CONFIG REQUIRED)
|
|
+ set(Zip_LIBRARIES libzip::zip)
|
|
+ set(Zip_FOUND TRUE)
|
|
+else()
|
|
+ set(Zip_LIBRARIES "")
|
|
+ set(Zip_FOUND FALSE)
|
|
+endif()
|
|
|
|
# Define a test flag for have curl library
|
|
IF(Zip_FOUND)
|
|
diff --git a/netCDFConfig.cmake.in b/netCDFConfig.cmake.in
|
|
index b3be259..72b4b25 100644
|
|
--- a/netCDFConfig.cmake.in
|
|
+++ b/netCDFConfig.cmake.in
|
|
@@ -15,6 +15,9 @@ set(netCDF_LIBRARIES netCDF::netcdf)
|
|
include(CMakeFindDependencyMacro)
|
|
find_dependency(HDF5 CONFIG)
|
|
find_dependency(CURL CONFIG)
|
|
+if(@ENABLE_NCZARR_ZIP@)
|
|
+ find_dependency(libzip CONFIG)
|
|
+endif()
|
|
include("${CMAKE_CURRENT_LIST_DIR}/netCDFTargets.cmake")
|
|
|
|
# Compiling Options
|