mirror of
https://github.com/microsoft/vcpkg.git
synced 2024-12-29 20:23:41 +08:00
d53488c65d
* [libjpeg-turbo] Update to libjpeg-turbo 2.0.1 * [libjpeg-turbo] workaround CMAKE_SYSTEM_PROCESSOR vcpkg bug
14 lines
610 B
Diff
14 lines
610 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index b2f137a..3754095 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -40,7 +40,7 @@ message(STATUS "VERSION = ${VERSION}, BUILD = ${BUILD}")
|
|
|
|
# Detect CPU type and whether we're building 64-bit or 32-bit code
|
|
math(EXPR BITS "${CMAKE_SIZEOF_VOID_P} * 8")
|
|
-string(TOLOWER ${CMAKE_SYSTEM_PROCESSOR} CMAKE_SYSTEM_PROCESSOR_LC)
|
|
+string(TOLOWER "${CMAKE_SYSTEM_PROCESSOR}" CMAKE_SYSTEM_PROCESSOR_LC)
|
|
if(CMAKE_SYSTEM_PROCESSOR_LC MATCHES "x86_64" OR
|
|
CMAKE_SYSTEM_PROCESSOR_LC MATCHES "amd64" OR
|
|
CMAKE_SYSTEM_PROCESSOR_LC MATCHES "i[0-9]86" OR
|