mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-15 09:38:20 +08:00
079a19c9bb
* openexr: Bump to 2.5.8 The x-add-version and patch fixes will be in next commits. * openexr: vcpkg.json: Use "version" instead of "version-string" * openexr: vcpkg.json: Add SPDX license identifier * openexr: Clean 0001*-find_package patch As upstream has cleaned it up already. * openexr: Clean 0002-fixup_cmake_exports** patch from old whitespace fix The upstream was already fixed it. * openexr: Drop symlinks and find-pkg patches as it were handled at upstream * openexr: Fix ARM build See upstream fix for details in openexr/openexr#1216: https://github.com/AcademySoftwareFoundation/openexr/pull/1216 * openexr: Migrate the old function to new vcpkg-cmake-config helpers * openexr/portfile: Add comment about version for commit revision * openexr: Update baseline via `vcpkg x-add-version openexr'
39 lines
1.8 KiB
Diff
39 lines
1.8 KiB
Diff
diff --git a/OpenEXR/config/OpenEXRSetup.cmake b/OpenEXR/config/OpenEXRSetup.cmake
|
|
index 5116726..34c7c87 100644
|
|
--- a/OpenEXR/config/OpenEXRSetup.cmake
|
|
+++ b/OpenEXR/config/OpenEXRSetup.cmake
|
|
@@ -33,7 +33,7 @@ endif()
|
|
# Whether to build & install the various command line utility programs
|
|
option(OPENEXR_BUILD_UTILS "Enables building of utility programs" ON)
|
|
|
|
-# This is a variable here for use in controlling where include files are
|
|
+# This is a variable here for use in controlling where include files are
|
|
# installed. Care must be taken when changing this, as many things
|
|
# probably assume this is OpenEXR
|
|
set(OPENEXR_OUTPUT_SUBDIR OpenEXR CACHE STRING "Destination sub-folder of the include path for install")
|
|
diff --git a/OpenEXR_Viewers/CMakeLists.txt b/OpenEXR_Viewers/CMakeLists.txt
|
|
index 5efa353..5246fa7 100644
|
|
--- a/OpenEXR_Viewers/CMakeLists.txt
|
|
+++ b/OpenEXR_Viewers/CMakeLists.txt
|
|
@@ -24,8 +24,6 @@ project(OpenEXR_Viewers VERSION ${OPENEXR_VIEWERS_VERSION})
|
|
#######################################
|
|
include(config/OpenEXRViewersSetup.cmake)
|
|
|
|
-find_package(IlmBase ${OPENEXR_VIEWERS_VERSION} EXACT REQUIRED CONFIG)
|
|
-find_package(OpenEXR ${OPENEXR_VIEWERS_VERSION} EXACT REQUIRED CONFIG)
|
|
|
|
# This is for newer cmake versions who know about vendor versions
|
|
set(OpenGL_GL_PREFERENCE GLVND)
|
|
diff --git a/PyIlmBase/CMakeLists.txt b/PyIlmBase/CMakeLists.txt
|
|
index 291b96e..7d5074f 100644
|
|
--- a/PyIlmBase/CMakeLists.txt
|
|
+++ b/PyIlmBase/CMakeLists.txt
|
|
@@ -27,7 +27,6 @@ project(PyIlmBase VERSION ${PYILMBASE_VERSION} LANGUAGES C CXX)
|
|
include(config/PyIlmBaseSetup.cmake)
|
|
|
|
# we have a strong dependence on IlmBase being an exact match
|
|
-find_package(IlmBase ${PYILMBASE_VERSION} EXACT REQUIRED CONFIG)
|
|
|
|
# we are building a python extension, so of course we depend on
|
|
# python as well. Except we don't know which version...
|