mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-07 21:05:21 +08:00
c7f99a77a8
* [double-conversion] Bump to 3.1.0 This release also allows removing the workarounds for calling vcpkg_fixup_cmake_targets twice after renaming *LibraryDepends.cmake because upstream didn't install *Targets.cmake files. That in turn fixes using double-conversion on Linux. * [harfbuzz] Fix cmake configs When building cmake with autotools, a harfbuzz-config.cmake file gets installed that makes find_package work. However when building with cmake, that is omitted. Therefore include a patch from upstream pull request https://github.com/harfbuzz/harfbuzz/pull/1161 to fix that. * [harfbuzz] Rename targets to unofficial-harfbuzz because they are not provided by upstream
23 lines
734 B
Diff
23 lines
734 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index e881dbd1..69496561 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -761,11 +761,17 @@ endif ()
|
|
|
|
if (NOT SKIP_INSTALL_LIBRARIES AND NOT SKIP_INSTALL_ALL)
|
|
install(TARGETS harfbuzz
|
|
+ EXPORT harfbuzzConfig
|
|
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
|
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
|
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
|
|
FRAMEWORK DESTINATION Library/Frameworks
|
|
)
|
|
+ install(EXPORT harfbuzzConfig
|
|
+ NAMESPACE unofficial::harfbuzz::
|
|
+ FILE unofficial-harfbuzz-config.cmake
|
|
+ DESTINATION share/unofficial-harfbuzz
|
|
+ )
|
|
if (HB_BUILD_UTILS)
|
|
install(TARGETS hb-view
|
|
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
|