mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-06 03:18:56 +08:00
146797a23b
* [hiredis] update to 1.1.0 * update version * revert patch format * update version * fix deps * fix deps * fix-duplicate * fix dependency * fix deps * fix portfile * fix deps * why os fail * delete nouse patch * CI [skip actions] * CI [skip actions] * CI [skip actions] * split patch * forget delete one line * forget delete one line * fix example * Revert "fix example" This reverts commit 282f8af68180ddae9d3ee198f36091363e436b0f. * CI [skip actions] * CI [skip actions] * CI [skip actions] * CI [skip actions] * CI [skip actions] * CI [skip actions] * CI [skip actions] * CI * fix deps * CI * fix deps * fix deps --------- Co-authored-by: Jonliu1993 <13720414433@163.com>
23 lines
792 B
Diff
23 lines
792 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index d175f0a..fca0ee8 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -108,7 +108,7 @@ INSTALL(TARGETS hiredis
|
|
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
|
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
|
|
|
|
-if (MSVC)
|
|
+if (MSVC AND BUILD_SHARED_LIBS)
|
|
INSTALL(FILES $<TARGET_PDB_FILE:hiredis>
|
|
DESTINATION ${CMAKE_INSTALL_BINDIR}
|
|
CONFIGURATIONS Debug RelWithDebInfo)
|
|
@@ -197,7 +197,7 @@ IF(ENABLE_SSL)
|
|
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
|
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
|
|
|
|
- if (MSVC)
|
|
+ if (MSVC AND BUILD_SHARED_LIBS)
|
|
INSTALL(FILES $<TARGET_PDB_FILE:hiredis_ssl>
|
|
DESTINATION ${CMAKE_INSTALL_BINDIR}
|
|
CONFIGURATIONS Debug RelWithDebInfo)
|