mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-06 03:18:56 +08:00
146797a23b
* [hiredis] update to 1.1.0 * update version * revert patch format * update version * fix deps * fix deps * fix-duplicate * fix dependency * fix deps * fix portfile * fix deps * why os fail * delete nouse patch * CI [skip actions] * CI [skip actions] * CI [skip actions] * split patch * forget delete one line * forget delete one line * fix example * Revert "fix example" This reverts commit 282f8af68180ddae9d3ee198f36091363e436b0f. * CI [skip actions] * CI [skip actions] * CI [skip actions] * CI [skip actions] * CI [skip actions] * CI [skip actions] * CI [skip actions] * CI * fix deps * CI * fix deps * fix deps --------- Co-authored-by: Jonliu1993 <13720414433@163.com>
23 lines
891 B
Diff
23 lines
891 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index fca0ee8..b67888e 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -134,7 +134,7 @@ export(EXPORT hiredis-targets
|
|
if(WIN32)
|
|
SET(CMAKE_CONF_INSTALL_DIR share/hiredis)
|
|
else()
|
|
- SET(CMAKE_CONF_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}/cmake/hiredis)
|
|
+ SET(CMAKE_CONF_INSTALL_DIR share/hiredis)
|
|
endif()
|
|
SET(INCLUDE_INSTALL_DIR include)
|
|
include(CMakePackageConfigHelpers)
|
|
@@ -216,7 +216,7 @@ IF(ENABLE_SSL)
|
|
if(WIN32)
|
|
SET(CMAKE_CONF_INSTALL_DIR share/hiredis_ssl)
|
|
else()
|
|
- SET(CMAKE_CONF_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}/cmake/hiredis_ssl)
|
|
+ SET(CMAKE_CONF_INSTALL_DIR share/hiredis_ssl)
|
|
endif()
|
|
configure_package_config_file(hiredis_ssl-config.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/hiredis_ssl-config.cmake
|
|
INSTALL_DESTINATION ${CMAKE_CONF_INSTALL_DIR}
|