mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-07 21:05:21 +08:00
297ff7ba3e
* Consolidate netcdf-c ZLIB patching * Update to 4.8.1, refresh patches * Resolve parameter warning * Decouple netcdf-4 feature from hdf5 * Expose NCZarr features * Break vcpkg CI cascade * Fix hdf5 szip support detection for static linkage * Allow curl, hdf5, libzip with minimal dependencies * Disable fatal warnings on uwp * Update versions * Fix libzip dependency * Fix and simplify szip config patch * Revert nczarr-s3 feature for now * Update versions * [skip actions] CI * [skip actions] Debug ci failure * Revert "[skip actions] Debug ci failure" This reverts commit 03f3d52623026e9f16f8be067a07499aa5788b55.
14 lines
519 B
Diff
14 lines
519 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index c36908b..390ac0a 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -944,7 +944,7 @@ OPTION(ENABLE_BYTERANGE "Enable byte-range access to remote datasets.." OFF)
|
|
|
|
# Check for the math library so it can be explicitly linked.
|
|
IF(NOT WIN32)
|
|
- FIND_LIBRARY(HAVE_LIBM NAMES math m libm)
|
|
+ FIND_LIBRARY(HAVE_LIBM NAMES m libm math)
|
|
MESSAGE(STATUS "Found Math library: ${HAVE_LIBM}")
|
|
IF(NOT HAVE_LIBM)
|
|
MESSAGE(FATAL_ERROR "Unable to find the math library.")
|