mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-02 22:35:31 +08:00
134f30d95c
* [fluidsynth] Update to 2.3.2. The usage requirements patch is no longer required as a similar patch has been merged upstream. * [fluidsynth] Update CMake configure options. - List out the options per-platform. - Set the proper options for Android. * [fluidsynth] Update baseline. * [fluidsynth] On Linux, link dl before ALSA. * [fluidsynth] Update version. * [fluidsynth] Fully quote options passed to CMake. * [fluidsynth] Update version.
14 lines
450 B
Diff
14 lines
450 B
Diff
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
|
index 114fa163..2ea55ddc 100644
|
|
--- a/src/CMakeLists.txt
|
|
+++ b/src/CMakeLists.txt
|
|
@@ -365,7 +365,7 @@ if ( PULSE_SUPPORT )
|
|
endif()
|
|
|
|
if ( TARGET ALSA::ALSA AND ALSA_SUPPORT )
|
|
- target_link_libraries ( libfluidsynth-OBJ PUBLIC ALSA::ALSA )
|
|
+ target_link_libraries ( libfluidsynth-OBJ PUBLIC ALSA::ALSA ${CMAKE_DL_LIBS} )
|
|
endif()
|
|
|
|
if ( TARGET PortAudio::PortAudio AND PORTAUDIO_SUPPORT )
|