vcpkg/ports/libjpeg-turbo/workaround_cmake_system_processor.patch
MonicaLiu 14f7d2896e
[libjpeg-turbo] Update to 2.1.5.1. (#29781)
* update libjpeg-turbo

* update version

* Undo rxcpp changes

* update patch

* update version

---------

Co-authored-by: MonicaLiu <v-liumonica@microsoft.com>
Co-authored-by: Javier Matos Denizac <javier.matosd@gmail.com>
2023-02-27 11:57:38 -08:00

14 lines
523 B
Diff

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3730326..0c2b87c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,7 +66,7 @@ include(cmakescripts/PackageInfo.cmake)
# Detect CPU type and whether we're building 64-bit or 32-bit code
math(EXPR BITS "${CMAKE_SIZEOF_VOID_P} * 8")
-string(TOLOWER ${CMAKE_SYSTEM_PROCESSOR} CMAKE_SYSTEM_PROCESSOR_LC)
+string(TOLOWER "${CMAKE_SYSTEM_PROCESSOR}" CMAKE_SYSTEM_PROCESSOR_LC)
set(COUNT 1)
foreach(ARCH ${CMAKE_OSX_ARCHITECTURES})
if(COUNT GREATER 1)