vcpkg/ports/opencc/fix-dependencies.patch
Mengna Li 4ea3456f21
[opencc] De-vendor rapidjson (#26291)
* update opencc to v1.1.4 and add feature rapidjson

* update

* convert feature to dependence

* remove useless code
2022-08-12 15:46:15 -07:00

17 lines
355 B
Diff

diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 11d14e4..fde4b7b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -137,6 +137,11 @@ set_target_properties(
1.1
)
+if(USE_SYSTEM_RAPIDJSON)
+ find_package(RapidJSON CONFIG REQUIRED)
+ target_link_libraries(libopencc PRIVATE rapidjson)
+endif()
+
# Installation
install(