mirror of
https://github.com/microsoft/vcpkg.git
synced 2025-01-15 16:18:00 +08:00
4ea3456f21
* update opencc to v1.1.4 and add feature rapidjson * update * convert feature to dependence * remove useless code
17 lines
355 B
Diff
17 lines
355 B
Diff
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
|
index 11d14e4..fde4b7b 100644
|
|
--- a/src/CMakeLists.txt
|
|
+++ b/src/CMakeLists.txt
|
|
@@ -137,6 +137,11 @@ set_target_properties(
|
|
1.1
|
|
)
|
|
|
|
+if(USE_SYSTEM_RAPIDJSON)
|
|
+ find_package(RapidJSON CONFIG REQUIRED)
|
|
+ target_link_libraries(libopencc PRIVATE rapidjson)
|
|
+endif()
|
|
+
|
|
# Installation
|
|
|
|
install(
|